1 Reply Latest reply on Dec 23, 2014 6:07 AM by Andy Taylor

    HornetQ and Maven

    Peter Minearo Newbie

      First, I am new to HornetQ. 

       

      We have an Embedded ActiveMQ server within our application which starts up via Spring.  ActiveMQ has been causing some problems with restarts; so we are looking to replace it with HornetQ.  I am trying to set up the maven dependencies.  Looks like the latest version of HornetQ is 2.4.0.Final; except for the dependencies listed below.  Are the latest versions for these artifacts in the main maven repo?  Meaning, the latest version for  'hornetq-core' is 2.2.21.Final?  I got this list of dependencies from the following: http://hornetq.blogspot.com/2009/09/hornetq-simple-example-using-maven.html

       

      Also, is there a good article/forum post/example on how to embed HornetQ using Spring?

       

        <dependency>
        <groupId>org.hornetq</groupId>
        <artifactId>hornetq-core</artifactId>
        <version>2.4.0.Final</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>org.hornetq</groupId>
        <artifactId>hornetq-jms</artifactId>
        <version>2.4.0.Final</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>org.hornetq</groupId>
        <artifactId>hornetq-logging</artifactId>
        <version>2.4.0.Final</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>org.hornetq</groupId>
        <artifactId>hornetq-transports</artifactId>
        <version>2.4.0.Final</version>
        <scope>compile</scope>
        </dependency>