3 Replies Latest reply on Jan 7, 2015 3:44 PM by Wolf-Dieter Fink

    Jboss 6 client / WildFly 8.2 compatability

    Speedy Gonzales Newbie

      Can someone please tell me if jboss-client from v6 will work with WildFly 8.2 backend?

        • 1. Re: Jboss 6 client / WildFly 8.2 compatability
          Tomaz Cerar Master

          No it wont.

           

          Just use client libs from wildfly 8.2, they can be used in jboss as 6 server to connect to wildfly 8.2 if that is what you are after

          1 of 1 people found this helpful
          • 2. Re: Jboss 6 client / WildFly 8.2 compatability
            Speedy Gonzales Newbie

            Thank you for your reply.

             

            I'm more after migrating stand-alone clients which are currently using jboss-client to connect to our existing JBAS61 infra.

             

            Perhaps it would help if I explain what we're trying to achieve. Currently we have a couple of apps using jboss-client to connect to stand-alone JBAS61 instance(s) hosting a handful of stateful/stateless beans. We need to move to a distributed/clustered environment. Initially I was planning to cluster AS16 and have the clients migrated to HA-JNDI but then it was decided to upgrade to WildFly 8.2 to benefit from all the new features and improvements.

             

            Any suggestions on how to achieve that without having to drastically rewrite the client side?

            • 3. Re: Jboss 6 client / WildFly 8.2 compatability
              Wolf-Dieter Fink Master

              There are major changes since AS6, you need to change the client code to use WF8.

              As you want to have clustering you cant use the remote-naming.

              You should use the ejb-client and here you can use the property based approach or the programatic one depend on your requirements.

              See WF documentation for more details.

              1 of 1 people found this helpful