0 Replies Latest reply on Jan 7, 2015 11:41 AM by Vijay Bhoomireddy

    Infinispan not picking the configuration

    Vijay Bhoomireddy Newbie

      Hi,

       

      We are new to Infinispan and trying to setup a cluster on EC2 machines with a distributed cache mechanism.

       

      We are putting entries into the cache where multiple threads are pumping data into the distributed cache. When we do this, we are seeing an error

       

      org.infinispan.util.concurrent.TimeoutException: Unable to acquire lock after [0 milliseconds] on key [24108] for requestor [Thread[remote-thread-2,5,main]]! Lock held by [[Thread[remote-thread-6,5,main]

       

      As I understand by readin various articles over the internet, setting "useLockStriping" to false should overcome this issue. However, even after using the below configuration, we are still facing the same issue. As you can see, in the below configuration, we have set the lockAcquisitionTimeout as 500. But still in the error message printed in the console, we are ssing the message as "Unable to acquire lock after [0 milliseconds]"

       

      Is this happening because Infinispan is not able to pick the configuration mentioned in the xml file? But, when I print the configuration information using cacheManager.getDefaultCacheConfiguration(), I could see all the configuration printing properly, but still the error prevails.

       

      Can anyone please let me know what step is being performed wrongly and what needs to be done to get this working?

       

      <?xml version="1.0" encoding="UTF-8"?>

      <infinispan xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

                  xmlns="urn:infinispan:config:6.0"

                  xsi:schemaLocation="urn:infinispan:config:6.0 http://www.infinispan.org/schemas/infinispan-config-6.0.xsd">

         <global>

              <transport>

                  <properties>

                      <property name="configurationFile" value="jgroups.xml" />

                  </properties>

              </transport>

          </global>

       

         <!-- Default configuration is appropriate for entity/collection caching. -->

         <default>

         <locking isolationLevel="READ_COMMITTED" concurrencyLevel="1000"

                     lockAcquisitionTimeout="500" useLockStriping="false" writeSkewCheck="false"/>

        

            <clustering mode="distribution">

              <async/>

              <hash numOwners="1"/>

              </clustering>                       

            <jmxStatistics enabled="false" />                    

         </default>

       

      </infinispan>

       

       

       

      Thanks & Regards

      Vijay