6 Replies Latest reply on Nov 6, 2017 7:01 AM by Pradeep Mittal

    Attachments: ClassNotFoundException: org.jbpm.document.marshalling.DocumentMarshallingStrategy

    Roger Parkinson Newbie

      I'm trying to follow the instructions on http://docs.jboss.org/jbpm/v6.1/userguide/chap-formmodeler.html#sect-formmodeler-attachments

      • added a Variable Definition 'document' with custom type org.jbpm.document.Document to my process
      • clicked on generate all forms: this put a document upload field onto the process form, but not the others. No problem, I can add those manually.
      • Added the reference to org.jbpm.document.marshalling.DocumentMarshallingStrategy into my kie-deployment-descriptor file
      • added the references to kie-api and jbpm-document to my pom.xml and rebuilt my war file
      • tried to build & deploy the process and I get ClassNotFound looking for org.jbpm.document.marshalling.DocumentMarshallingStrategy

      I've checked that the relevant jar files are in the WEB-INF/lib of the war file and redeployed it.

      I tried adding those dependencies to the pom file in the process: same error

      I also tried adding those jar file to the lib/ext of my wildfly server: same error

      Is there something else I need to do here? The docs suggest I ought to be writing my own version of DocumentMarshallingStrategy but it is unclear as to why I should, it is just a simple marshaling exercise. And as far as I can tell I just need to stick it on the classpath, and I have (3 times over) but it still doesn't find it.


      My environment is:

      jdk1.7.0_67

      Wildfly-8.1.0.Final

      kie-wb-6.1.0.Final-wildfly.war (I've built this from https://github.com/droolsjbpm/kie-wb-distributions.git, with some tweaks to make it use a postgres database)