0 Replies Latest reply on Jan 30, 2015 3:32 AM by Johannes Hoffmeister

    Timeout Exception with load after updating infinispan (No Code change!) wrong config update?

    Johannes Hoffmeister Newbie

      Hi,

       

      Ive updated infinispan 5.3.0 to 7.0.0.

       

      Im using infinispan-core-7.0.0.Final.jar and infinispan-commons-7.0.0.Final.jar now after using 5.3.0 core. Of course i had to update the infinispan config since thats the place where i configured the caches. I didnt change any code and its running fine but with some higher load the im getting timeout exceptions and the server crashes.

       

      Caused by: org.infinispan.util.concurrent.TimeoutException: ISPN000299: Unable to acquire lock after 30 seconds for key fake-event292162@bmw.de and requestor RecoveryAwareDldGlobalTransaction{xid=< 4871251, 48, 42, 1035830-11460-848108105971121124948494698109119103114111117112461101011164410548951081059711211249484944805056535552, 108105971121124948494698109119103114111117112461101011164410548951081059711211249484944805056535552440 >, internalId=281479271681823} DldGlobalTransaction{coinToss=662724114750600211, lockIntention=fake-event292162, affectedKeys=[], locksAtOrigin=[]} GlobalTransaction:<liapp101-49129>:215638:remote. Lock is held by RecoveryAwareDldGlobalTransaction{xid=< 4871251, 48, 42, 304040-95-621649108105971121124948504698109119103114111117112461101011164410548951081059711211249485044805056535552, 108105971121124948504698109119103114111117112461101011164410548951081059711211249485044805056535552440 >, internalId=281483566651735} DldGlobalTransaction{coinToss=-2385123348430289671, lockIntention=null, affectedKeys=[], locksAtOrigin=[]} GlobalTransaction:<liapp102-65479>:275296:local, while request came from liapp101-49129

       

       

       

      This is my old config:

       

      <?xml version="1.0" encoding="UTF-8"?>

      <infinispan xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="urn:infinispan:config:5.2 http://www.infinispan.org/schemas/infinispan-config-5.2.xsd"

        xmlns="urn:infinispan:config:5.3">

       

        <!-- Global cache/cluster settings -->

        <global>

          <!-- <globalJmxStatistics enabled="true" /> -->

          <transport clusterName="infinispanCluster">

            <properties>

              <property name="configurationFile" value="jgroups-tcp-ccc.xml" />

            </properties>

          </transport>

          <shutdown hookBehavior="DEFAULT" />

        </global>

       

        <!-- Default Cache -->

        <default>

          <clustering mode="distribution">

            <l1 enabled="true" lifespan="60000" />

            <hash numOwners="2" />

            <sync replTimeout="200000" />

          </clustering>

          <locking lockAcquisitionTimeout="30000" concurrencyLevel="1000" useLockStriping="false" />

          <transaction autoCommit="true" transactionMode="TRANSACTIONAL" lockingMode="OPTIMISTIC" />

        </default>

       

        <!-- All Service Requests Cache -->

        <namedCache name="allServiceRequests">

          <clustering mode="distribution">

            <l1 enabled="true" lifespan="60000" />

            <hash numOwners="2" />

            <sync replTimeout="200000" />

          </clustering>

          <locking lockAcquisitionTimeout="30000" concurrencyLevel="1000" useLockStriping="false" />

          <transaction autoCommit="true" transactionMode="TRANSACTIONAL" lockingMode="PESSIMISTIC" />

        </namedCache>

       

        <!-- EventIds Cache -->

        <namedCache name="eventIds">

          <clustering mode="distribution">

            <l1 enabled="true" lifespan="60000" />

            <hash numOwners="2" />

            <sync replTimeout="200000" />

          </clustering>

          <locking lockAcquisitionTimeout="30000" concurrencyLevel="1000" useLockStriping="false" />

          <transaction autoCommit="true" transactionMode="TRANSACTIONAL" lockingMode="PESSIMISTIC" />

        </namedCache>

       

       

        <!-- Traffic interface URLs Cache -->

        <namedCache name="trafficUrls">

          <clustering mode="distribution">

            <l1 enabled="true" lifespan="60000" />

            <hash numOwners="2" />

            <sync replTimeout="200000" />

          </clustering>

          <locking lockAcquisitionTimeout="30000" concurrencyLevel="1000" useLockStriping="false" />

          <deadlockDetection enabled="false" />

          <transaction autoCommit="true" transactionMode="TRANSACTIONAL" lockingMode="PESSIMISTIC" />

        </namedCache>

       

      </infinispan>

       

      And this is my new config (should be exactly the same??):

       

      <?xml version="1.0" encoding="UTF-8"?>

      <infinispan

            xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

            xsi:schemaLocation="urn:infinispan:config:7.0 http://www.infinispan.org/schemas/infinispan-config-7.0.xsd"

            xmlns="urn:infinispan:config:7.0">

       

         <jgroups>

            <stack-file name="tcp" path="jgroups-tcp-ccc.xml"/>

         </jgroups>

        

         <cache-container name="infinispanCluster" statistics="true"  default-cache="the-default-cache" shutdown-hook="DEFAULT">

          <transport stack="tcp"/>

         

             <distributed-cache name="the-default-cache" mode="SYNC" remote-timeout="200000" owners="2" l1-lifespan="60000" deadlock-detection-spin="100">

              <locking striping="false" acquire-timeout="30000" concurrency-level="1000" />

              <transaction auto-commit="true" mode="NON_XA" locking="OPTIMISTIC" />

             </distributed-cache>

            

             <distributed-cache name="allServiceRequests" mode="SYNC" remote-timeout="200000" owners="2" l1-lifespan="60000" deadlock-detection-spin="100">

              <locking striping="false" acquire-timeout="30000" concurrency-level="1000" />

              <transaction auto-commit="true" mode="NON_XA" locking="PESSIMISTIC" />

             </distributed-cache>

            

             <distributed-cache name="eventIds" mode="SYNC" remote-timeout="200000" owners="2" l1-lifespan="60000" deadlock-detection-spin="100">

              <locking striping="false" acquire-timeout="30000" concurrency-level="1000" />

              <transaction auto-commit="true" mode="NON_XA" locking="PESSIMISTIC" />

             </distributed-cache>

       

              <distributed-cache name="trafficUrls" mode="SYNC" remote-timeout="200000" owners="2" l1-lifespan="60000" >

              <locking striping="false" acquire-timeout="30000" concurrency-level="1000" />

              <transaction auto-commit="true" mode="NON_XA" locking="PESSIMISTIC" />

             </distributed-cache>

         </cache-container>

      </infinispan>

       

       

      Am i missing something here? i dont get it for what ive read in the user doku it should be exactly the same configuration ( Transaction mode, locking setting etc.. ). Would be great if someone knows whats wrong maybe im just to blind to see it.