1 Reply Latest reply on Feb 10, 2015 5:39 AM by Rafael Pestano

    Arquillian persistence @CreateSchema never triggered

    Yan Langlois Newbie

      Hi,

       

      I would like to test a webapp with both Drone and presistence extension. My anotation @CreateSchema is never trigerred. Here is my arquillian.xml file :

      <?xml version="1.0" encoding="UTF-8"?>
      <arquillian>
         <defaultProtocol type="Servlet 3.0" />
         <container qualifier="jboss" default="true">
         
         </container>
          <engine>
          </engine>
          <extension qualifier="graphene">
             <property name="waitGuardInterval">20</property>
          </extension>
          <extension qualifier="webdriver">
              <property name="version">firefox</property>
          </extension>
          <extension qualifier="persistence">
              <property name="defaultDataSource">java:/datasources/standardDS</property>
          </extension>
      </arquillian>
      

       

      Here is my test class :

      @CreateSchema({"create.sql"})
      @RunWith(Arquillian.class)
      public class MyTest {
      ...
      }
      

       

      When I debug persistences classes, I see that my create.sql file is well known by arquillian. But the script executions are never triggered. I use

           - arquillian 1.1.5.Final

           - arquillian drone 2.0.0.Alpha3

           - arquillian persistence 1.0.0.Alpha7

           - arquillian graphene 2.1.0.Alpha1