0 Replies Latest reply on Aug 18, 2005 5:12 AM by keith doyle

    jboss4.0.2, hibernate3 and mysql?

    keith doyle Newbie

      Just a quick post to let u know how I solved problems with this set-up:

      This combo did not work for me - all the table names when created were generated with two preceeding underscores, queries would not work and getter/setter methods for the pks threw exceptions. Yes I ran the fix for the missing jar - yes I tried all sorts of ears,wars,hars and sars !!! Having never used hibernate before it took me TWO days to resolve i.e. I tought it was something I was doing!!!! Anyway if you wish to avoid a swirling torrent of pain and misery here's my solution:

      1. - Download jboss4.0.1sp1 (this uses hibernate2).
      2. - I then made a copy of my code and converted the imports for hibernate2. You also need to change the .hbms and the class references in hibernate-service.xml. This is not a painful as it sounds. This allowed my to check my solution actually worked - which it now did.
      3. - Now remove the jboss-hibernate.deployer directory from 4.0.1 and replace it with the directory from 4.0.2 (nuts eh?)
      4. - Try your hibernate3 code. It should work as expected.