5 Replies Latest reply on Feb 18, 2015 3:23 PM by Roger Parkinson

    Activity Not Found in WB

    Roger Parkinson Newbie

      I'm running WB  6.2.0-SNAPSHOT, a fresh build, under WildFly 8.1.0.Final.

      I log in and click on Project Authoring

      A popup appears saying 'Activity Not Found'

      Nothing in the log apart from the startup stuff and nothing alarming in there that I can see.

      Also I know there are processes in the repo but when I click on Process Definitions there are none listed.

       

      I can't think of anything I've changed since the last time I ran this (sometime last week) but I got this as soon as tried it today (in a demo....)

      There's another demo coming up so I hope the answer is easy.

       

      Here's a screenshot:

      ActivityNotFound.png

      I've attached the whole log but the only thing that looks odd to me is the very last line:

      "2015-02-18 17:08:32,891 INFO  [org.uberfire.backend.server.plugin.RuntimePluginsServiceServerImpl] (default task-61) Not listing directory content for frameworks/*.js because getRealPath() is returning null. (This app is probably deployed in an unexploded .war)"

      I don't know what that means, well I do know I'm deploying an unexploded war file, but that's what I always do.

      Grateful for any help

      R

        • 1. Re: Activity Not Found in WB
          Roger Parkinson Newbie

          I just went back to my 'known good' copy of Wlidlfy, ie no repositories, no history etc, and deployed the WB to that.

          Same problem. Is this because I'm working with SNAPSHOT and subject to temporary bugs in the bleeding edge version?

          Fair enough. it puts me in a bind tho' 'cos the 6.2.0.CR4 has a show stopper bug in it (doesn't display task forms).

          So here's hoping for a fix real soon.

          R

          • 2. Re: Activity Not Found in WB
            Mauricio Salatino Master

            Hi Roger, using SNAPSHOTS should be ok 90% of the time, but from time to time, when we do big refactorings this things tend to happen for all the team.

            Can you please let me know which repositories are you building locally? The more things that you build locally the less time you need to wait for jenkins to provide the new builds.

            Also when was the last time that you did update/pull the changes from the repositories?

            • 3. Re: Activity Not Found in WB
              Roger Parkinson Newbie

              Hi Mauricio. I understand that you need to refactor etc and that SNAPSHOTS is where it has to happen.

              So this is very much my problem, however keen I am to see it fixed.

               

              The only repository I am building locally is kie-wb-distributions, and actually I find I only need to build projects: kie-wb-webapp and kie-wb-distribution-wars

              I haven't pulled fresh code from that since 30 Jan, hmm maybe I should. Didn't think of that.

              The kie-wb-webapp build does pull a lot of snapshots down, so I guess there are lots of places to look

              • 4. Re: Activity Not Found in WB
                Mauricio Salatino Master

                Ok I see your problem then.

                If you are relying on snapshots you should pull the kie-wb-distributions everyday, because all the other projects are constantly updated and if something changes the kie-wb-distribution dependencies will be updated and you will miss that.

                So try pulling from the kie-wb-distributions master repository and do a mvn clean install -U inside the kie-wb directory to see if that fixes the issue.

                And let me know.. if that doesn't work we can try some other alternatives.

                • 5. Re: Activity Not Found in WB
                  Roger Parkinson Newbie

                  Thanks Mauricio. I did exactly as you said and it looks fine now.