2 Replies Latest reply on May 18, 2015 2:00 AM by Andreas Wagner

    WildFly behind apache2 with mod_jk

    Andreas Wagner Newbie

      Hi!

       

       

      After we solved some problem with mod_proxy and wildfly (see https://developer.jboss.org/thread/251358), again we sometimes realized some long response-times. That's why we decided to try with mod_jk instead of mod_proxy. Until now it is running without any problems. But we saw some of following log messages in the log.

       

      WildFly server.log

       

      2015-02-18 08:18:30,232 ERROR [io.undertow.request] (default I/O-3) UT005001: An exception occurred processing the request: java.lang.IllegalArgumentException: Unknown method type -1
               at io.undertow.server.protocol.ajp.AjpRequestParser.parse(AjpRequestParser.java:202)
               at io.undertow.server.protocol.ajp.AjpReadListener.handleEvent(AjpReadListener.java:125)
               at io.undertow.server.protocol.ajp.AjpReadListener.handleEvent(AjpReadListener.java:35)
               at org.xnio.ChannelListeners.invokeChannelListener(ChannelListeners.java:92) [xnio-api-3.2.2.Final.jar:3.2.2.Final]
               at org.xnio.conduits.ReadReadyHandler$ChannelListenerHandler.readReady(ReadReadyHandler.java:66) [xnio-api-3.2.2.Final.jar:3.2.2.Final]
               at org.xnio.nio.NioSocketConduit.handleReady(NioSocketConduit.java:87) [xnio-nio-3.2.2.Final.jar:3.2.2.Final]
               at org.xnio.nio.WorkerThread.run(WorkerThread.java:539) [xnio-nio-3.2.2.Final.jar:3.2.2.Final]
      
      2015-02-18 08:18:30,580 ERROR [io.undertow.request] (default I/O-5) UT005001: An exception occurred processing the request: java.lang.IllegalArgumentException: Unknown method type -1
               at io.undertow.server.protocol.ajp.AjpRequestParser.parse(AjpRequestParser.java:202)
               at io.undertow.server.protocol.ajp.AjpReadListener.handleEvent(AjpReadListener.java:125)
               at io.undertow.server.protocol.ajp.AjpReadListener.handleEvent(AjpReadListener.java:35)
               at org.xnio.ChannelListeners.invokeChannelListener(ChannelListeners.java:92) [xnio-api-3.2.2.Final.jar:3.2.2.Final]
               at org.xnio.conduits.ReadReadyHandler$ChannelListenerHandler.readReady(ReadReadyHandler.java:66) [xnio-api-3.2.2.Final.jar:3.2.2.Final]
               at org.xnio.nio.NioSocketConduit.handleReady(NioSocketConduit.java:87) [xnio-nio-3.2.2.Final.jar:3.2.2.Final]
               at org.xnio.nio.WorkerThread.run(WorkerThread.java:539) [xnio-nio-3.2.2.Final.jar:3.2.2.Final]
      
      

       

      mod_jk log

      [Wed Feb 18 08:18:30.251 2015] [622:140533720663808] [info] ajp_connection_tcp_get_message::jk_ajp_common.c (1266): (ajp13) can't receive the response header message from tomcat, tomcat (127.0.0.1:8009) has forced a connection close for socket 18
      [Wed Feb 18 08:18:30.480 2015] [622:140533720663808] [error] ajp_get_reply::jk_ajp_common.c (2118): (ajp13) Tomcat is down or refused connection. No response has been sent to the client (yet)
      [Wed Feb 18 08:18:30.480 2015] [622:140533720663808] [info] ajp_service::jk_ajp_common.c (2607): (ajp13) sending request to tomcat failed (recoverable),  (attempt=1)
      [Wed Feb 18 08:18:30.600 2015] [622:140533720663808] [info] ajp_connection_tcp_get_message::jk_ajp_common.c (1266): (ajp13) can't receive the response header message from tomcat, tomcat (127.0.0.1:8009) has forced a connection close for socket 20
      [Wed Feb 18 08:18:30.600 2015] [622:140533720663808] [error] ajp_get_reply::jk_ajp_common.c (2118): (ajp13) Tomcat is down or refused connection. No response has been sent to the client (yet)
      [Wed Feb 18 08:18:30.600 2015] [622:140533720663808] [info] ajp_service::jk_ajp_common.c (2607): (ajp13) sending request to tomcat failed (recoverable),  (attempt=2)
      [Wed Feb 18 08:18:30.600 2015] [622:140533720663808] [error] ajp_service::jk_ajp_common.c (2626): (ajp13) connecting to tomcat failed.
      [Wed Feb 18 08:18:30.601 2015] [622:140533720663808] [info] jk_handler::mod_jk.c (2678): Service error=0 for worker=ajp13
      
      

       

      worker.properties

      worker.ajp13.type=ajp13
      worker.ajp13.host=localhost
      worker.ajp13.port=8009
      worker.ajp13.lbfactor=1
      
      

       

      Anyone have an idea what the problem could be?

      Thanks in advance.