0 Replies Latest reply on Feb 23, 2015 8:08 AM by Eric Pot

    Unable to use deployed JDBC driver in WildFly 8.2.0 Domain mode

    Eric Pot Newbie

      In standalone mode I am able to successfully deploy the JDBC driver mariadb-java-client-1.1.8.jar. Also connecting to the DB works like a charme.

       

      If I start WildFly in domain mode the same driver seems to deploy without problem, see output from log below:

       

      2015-02-23 13:46:16,406 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: WildFly 8.2.0.Final "Tweek" started in 6634ms - Started 211 of 260 services (90 services are lazy, passive or on-demand)

      2015-02-23 13:46:48,346 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-3) JBAS015876: Starting deployment of "mariadb" (runtime-name: "mariadb-java-client-1.1.8.jar")

      2015-02-23 13:46:49,022 INFO  [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-7) JBAS010404: Deploying non-JDBC-compliant driver class org.mariadb.jdbc.Driver (version 1.1)

      2015-02-23 13:46:49,044 INFO  [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-7) JBAS010417: Started Driver service with driver-name = mariadb-java-client-1.1.8.jar

      2015-02-23 13:46:49,384 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 58) JBAS018559: Deployed "mariadb" (runtime-name : "mariadb-java-client-1.1.8.jar")

       

      But, the driver is not available when creating a datasource. Till now I tried following steps without success:

       

      1) Try to deploy mysql-connector-java-5.1.34-bin.jar in the domain mode. This also doesn't work

      2) Tried to add it as standard module (directory com/mysq/main and adding module.xml), for both drivers without success.

       

      Could anybody give a suggestion?