0 Replies Latest reply on Feb 23, 2015 5:08 PM by Venu Rao

    Richfaces 4.5.1.Final not working with Jetty

    Venu Rao Newbie

      Hi,

       

      I am upgrading from Richfaces 3.3.2 to 4.5.1.Final. I had several issues but finally able to get my project to compile but when I run my application I do not see any of the Richfaces components to show or ajax events to fire. I am running this using Jetty server, just to test I deployed my war to Tomcat and it works fine in Tomcat, anyone knows if there is are any specific dependencies you need for Jetty. I have the following plugin in my parent pom file.

       

      <!-- Jetty web server plugin -->

                  <plugin>

                      <groupId>org.mortbay.jetty</groupId>

                      <artifactId>maven-jetty-plugin</artifactId>

                      <version>6.1.24</version>

                      <configuration>

                          <stopPort>9999</stopPort>

                          <stopKey>foo</stopKey>

                      </configuration>

                  </plugin>       

       

      and the following profile in my pom file.

                <profile>

                  <id>jetty</id>

                  <activation>

                      <property>

                          <name>app.server.type</name>

                          <value>jetty</value>

                      </property>

                  </activation>

              </profile>

       

      I would really appreciate it if someone can give me a clue where I am going wrong. I am attaching my pom files for reference.

       

      Thanks,

      Venu