1 Reply Latest reply on Mar 23, 2015 2:03 PM by Ondrej Zizka

    Is there some Windup rule for downgrade migration cases?

    Rafael Soares (Tuelho) Novice

      Hi!

      I was wondering if is possible to use Windup downgrade JavaEE apps to a specific App Server (enterprise version).

       

      for example: an app developed using JavaEE (EJB 3.2, JMS 2, JPA 2.1, JSF 2.2, JAX-RS 2, Batch, JSON, Websockets, etc) specs taht needs to be adapted to be deployed in JBoss EAP 6.x in production env.

       

      Some times we see apps developed for non enterprise Application Servers (Wildfly 8.x, Tomcat, TomEE, etc) using JavaEE new specs/features (JavaEE >= 7), but when it's time to go to a production env, customer faces the Enterprise App Server JavaEE compatibility (eg: JBoss EAP 6.x that implements JavaEE6 specs).

       

      So, I would like to use Windup to highlight the need for downgrade specific part of the app to the JavaEE target version in the Enterprise App Server.

       

      any consideration on this would be very appreciate.

       

      Kind regards.