2 Replies Latest reply on Mar 17, 2015 5:05 PM by David Baddeley

    Upgrading infinispan in JBoss AS7

    David Baddeley Newbie

      Hi All,

       

      Hoping some Jboss/Wildfly gurus can help me out!

       

      I am trying to update infinispan from the bundled 5.2.1 (ships with JBoss AS 7.2.0) to a more recent version

       

      I have downloaded 6.0.2 modules and added to the server, then made following updates to jboss-deployment-structure.xml

       

      <jboss-deployment-structure>

        <ear-subdeployments-isolated>false</ear-subdeployments-isolated> 

        <deployment>

              <!-- Replace shipped infinispan with 6.0 -->

              <module name="org.infinispan" slot="6.0"/>

                <module name="org.infinispan.client.hotrod" slot="6.0"/>

          </dependencies>

          <exclusions>

              <module name="org.infinispan" slot="main"/>

              <module name="org.infinispan.client.hotrod" slot="main"/>

           </exclusions>

        </deployment> 

      </jboss-deployment-structure>

       

      I even updated standalone-full-ha.xml to add:

       

             <subsystem xmlns="urn:jboss:domain:ee:1.1">

                  <global-modules>

                      <module name="org.infinispan" slot="6.0"/>

                  </global-modules>

              </subsystem>

       

      But each time I boot the server I get:

       

      19:05:12,901 INFO  [org.infinispan.factories.GlobalComponentRegistry] (ServerService Thread Pool -- 61) ISPN000128: Infinispan version: Infinispan 'Delirium' 5.2.1.Final

       

      I have also tried the same with the 7.0.3 modules download (using slot: ispn-7.0), with the same result

       

      Am I missing some extra config?