4 Replies Latest reply on Oct 6, 2017 2:00 PM by Prasanna Kumari

    WildFly 8.2.0 freezing

    helmutz Newbie

      I have a strange problem where parts of my WildFly instance occasionally (approximately once a day) freezes. My application consists of a Vaadin based webapp and Java applet based remote client. When the freezing occurs all the HTTP related stuff just stops working, ie webapp is not responding through browser and my remote EJB calls from the applet is not functioning anymore. However, other parts of the WildFly seems to be functioning normally, such as the management web interface and EJB containers.

       

      I'm not seeing any errors or warnings in the log file, and even after enabling debug messages I don't see anything strange. Only way to recover from the problem is to restart WildFly. It also seems that WildFly will not stop gracefully but I have to kill the process from Task Manager. I have been running almost the same installation on other servers as well without facing similar problems.

       

      I'm running WildFly 8.2.0 Final on Windows 2012

       

      Does anyone have any suggestion what might be wrong? Or how to debug the problem since I'm not seeing anything in WildFly logs?

        • 1. Re: WildFly 8.2.0 freezing
          Daniel Novo Newbie

          Hi

           

          Try using VisualVM to help you identify the problem.

           

          Probably wildfly has no threads available to process your request's.

           

          Also check this thread:

           

          Wildlfy 8.1 stops responding

          • 2. Re: WildFly 8.2.0 freezing
            helmutz Newbie

            Thank you, dnovo, I hadn't noticed that thread, which is somewhat similar to my problem. Unfortunately the problem in that thread does not seem to be solved.

             

            In my case VisualVM shows me that all my task threads are available (parking). However, one of the EJB threads seem to be deadlocked. How can i debug what is causing this deadlocking? Can the deadlocking of one EJB thread be the cause of this kind of behaviour (WildFly not responding to any HTTP requests), or is this deadlocking just a consequence of the same problem locking other parts of WildFly?

            Found one Java-level deadlock:

            =============================

            "EJB default - 1":

              waiting to lock monitor 0x000000002c0fcd28 (object 0x00000000b7366880, a java.util.ArrayDeque),

              which is held by "default I/O-5"

            "default I/O-5":

              waiting to lock monitor 0x0000000022623ac8 (object 0x00000000ff048350, a org.xnio.streams.BufferPipeOutputStream),

              which is held by "EJB default - 1"

            • 3. Re: WildFly 8.2.0 freezing
              Olawale Komolafe Newbie

              Hi @helmutz I've also encountered the same issue here. In my case, some background (Scheduler) tasks are still running even though wildfly does not respond HTTP requests.  Please share the means by which you have solved or reduce the occurrence of this issue to the barest minimum. Thanks.

              • 4. Re: WildFly 8.2.0 freezing
                Prasanna Kumari Newbie

                We are also seeing the same issue on Wildfly 8.2.0 Final. We have set the read-timeout as well as no-request-timeout parameters. Is there any other parameter that needs to be configured in the https listener of undertow? Do we need to tune any IO subsystem parameter?