1 Reply Latest reply on Sep 10, 2009 2:54 PM by Peter Johnson

    Linux UI Hangs with App Server Running

    Mark Howard Newbie

      Hi,

      I'm getting an odd error when running jboss app server on linux once the initialisation is finished.
      Various GUI applications become very sluggish or freeze, for example firefox takes several seconds to open a menu. The CPU and disk usage are both minimal (as reported by top and atop) and there is lots of free memory. As far as I can tell, the system is otherwise working correctly. The issue is definitely related to jboss app server because it starts when jboss starts and stops as soon as I stop the app server.
      As a result of this, jboss is effectively unusable on this machine.

      I don't get this problem if I run the minimal configuration of jboss, but do get the problem with the default, standard, all and web configurations.
      I'm running ubuntu 9.10 with kernel 2.6.31-9-generic. I get the same problem with jboss 5.0.1 and 5.1.0

      Any ideas what could be wrong or what else to try to debug this?
      I've already tried changing all the port definitions I could find, in case there was a conflict, but this didn't have any effect.

      If it helps, the output from starting up with the web configuration is below:

      ./bin/run.sh -b 0.0.0.0 -c web
      =========================================================================
      
       JBoss Bootstrap Environment
      
       JBOSS_HOME: /opt/jboss-5.1.0.GA
      
       JAVA: /usr/lib/jvm/java-6-sun/bin/java
      
       JAVA_OPTS: -Dprogram.name=run.sh -Xms128m -Xmx1024m -XX:MaxPermSize=256m -Dplatform=jboss -Dgrid.name=WrenGrid -Dls_license=/home/markh/workspace-rs/dev2009-all.lic -Dmulticast.group=228.1.2.4 -Dmulticast.port=47200 -Dcache.directory=/tmp -Djava.net.preferIPv4Stack=true
      
       CLASSPATH: /opt/jboss-5.1.0.GA/bin/run.jar:/usr/lib/jvm/java-6-sun/lib/tools.jar
      
      =========================================================================
      
      12:42:01,898 INFO [ServerImpl] Starting JBoss (Microcontainer)...
      12:42:01,898 INFO [ServerImpl] Release ID: JBoss [The Oracle] 5.1.0.GA (build: SVNTag=JBoss_5_1_0_GA date=200905221634)
      12:42:01,899 INFO [ServerImpl] Bootstrap URL: null
      12:42:01,899 INFO [ServerImpl] Home Dir: /opt/jboss-5.1.0.GA
      12:42:01,899 INFO [ServerImpl] Home URL: file:/opt/jboss-5.1.0.GA/
      12:42:01,899 INFO [ServerImpl] Library URL: file:/opt/jboss-5.1.0.GA/lib/
      12:42:01,899 INFO [ServerImpl] Patch URL: null
      12:42:01,900 INFO [ServerImpl] Common Base URL: file:/opt/jboss-5.1.0.GA/common/
      12:42:01,900 INFO [ServerImpl] Common Library URL: file:/opt/jboss-5.1.0.GA/common/lib/
      12:42:01,900 INFO [ServerImpl] Server Name: web
      12:42:01,900 INFO [ServerImpl] Server Base Dir: /opt/jboss-5.1.0.GA/server
      12:42:01,900 INFO [ServerImpl] Server Base URL: file:/opt/jboss-5.1.0.GA/server/
      12:42:01,900 INFO [ServerImpl] Server Config URL: file:/opt/jboss-5.1.0.GA/server/web/conf/
      12:42:01,900 INFO [ServerImpl] Server Home Dir: /opt/jboss-5.1.0.GA/server/web
      12:42:01,900 INFO [ServerImpl] Server Home URL: file:/opt/jboss-5.1.0.GA/server/web/
      12:42:01,900 INFO [ServerImpl] Server Data Dir: /opt/jboss-5.1.0.GA/server/web/data
      12:42:01,900 INFO [ServerImpl] Server Library URL: file:/opt/jboss-5.1.0.GA/server/web/lib/
      12:42:01,900 INFO [ServerImpl] Server Log Dir: /opt/jboss-5.1.0.GA/server/web/log
      12:42:01,901 INFO [ServerImpl] Server Native Dir: /opt/jboss-5.1.0.GA/server/web/tmp/native
      12:42:01,901 INFO [ServerImpl] Server Temp Dir: /opt/jboss-5.1.0.GA/server/web/tmp
      12:42:01,901 INFO [ServerImpl] Server Temp Deploy Dir: /opt/jboss-5.1.0.GA/server/web/tmp/deploy
      12:42:02,575 INFO [ServerImpl] Starting Microcontainer, bootstrapURL=file:/opt/jboss-5.1.0.GA/server/web/conf/bootstrap.xml
      12:42:03,121 INFO [VFSCacheFactory] Initializing VFSCache [org.jboss.virtual.plugins.cache.CombinedVFSCache]
      12:42:03,123 INFO [VFSCacheFactory] Using VFSCache [CombinedVFSCache[real-cache: null]]
      12:42:03,429 INFO [CopyMechanism] VFS temp dir: /opt/jboss-5.1.0.GA/server/web/tmp
      12:42:03,430 INFO [ZipEntryContext] VFS force nested jars copy-mode is enabled.
      12:42:04,889 INFO [ServerInfo] Java version: 1.6.0_15,Sun Microsystems Inc.
      12:42:04,889 INFO [ServerInfo] Java Runtime: Java(TM) SE Runtime Environment (build 1.6.0_15-b03)
      12:42:04,889 INFO [ServerInfo] Java VM: Java HotSpot(TM) Server VM 14.1-b02,Sun Microsystems Inc.
      12:42:04,889 INFO [ServerInfo] OS-System: Linux 2.6.31-9-generic,i386
      12:42:04,889 INFO [ServerInfo] VM arguments: -Dprogram.name=run.sh -Xms128m -Xmx1024m -XX:MaxPermSize=256m -Dplatform=jboss -Dgrid.name=WrenGrid -Dls_license=/home/markh/workspace-rs/dev2009-all.lic -Dmulticast.group=228.1.2.4 -Dmulticast.port=47200 -Dcache.directory=/tmp -Djava.net.preferIPv4Stack=true -Djava.endorsed.dirs=/opt/jboss-5.1.0.GA/lib/endorsed
      12:42:04,934 INFO [JMXKernel] Legacy JMX core initialized
      12:42:07,566 INFO [ProfileServiceBootstrap] Loading profile: ProfileKey@6ecec5[domain=default, server=default, name=web]
      12:42:17,756 WARN [AnnotationCreator] No ClassLoader provided, using TCCL: org.jboss.managed.api.annotation.ManagementComponent
      12:42:17,983 WARN [AnnotationCreator] No ClassLoader provided, using TCCL: org.jboss.managed.api.annotation.ManagementComponent
      12:42:18,083 INFO [TransactionManagerService] JBossTS Transaction Service (JTA version - tag:JBOSSTS_4_6_1_GA) - JBoss Inc.
      12:42:18,084 INFO [TransactionManagerService] Setting up property manager MBean and JMX layer
      12:42:18,442 INFO [TransactionManagerService] Initializing recovery manager
      12:42:18,649 INFO [TransactionManagerService] Recovery manager configured
      12:42:18,693 INFO [TransactionManagerService] Binding TransactionManager JNDI Reference
      12:42:18,712 INFO [TransactionManagerService] Starting transaction recovery manager
      12:42:19,298 INFO [AprLifecycleListener] The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-6-sun-1.6.0.15/jre/lib/i386/server:/usr/lib/jvm/java-6-sun-1.6.0.15/jre/lib/i386:/usr/lib/jvm/java-6-sun-1.6.0.15/jre/../lib/i386:/home/markh/apps/icu:/home/markh/apps/jprofiler4/bin/linux-x86/:/home/markh/bin/subversion/lib/::/usr/java/packages/lib/i386:/lib:/usr/lib
      12:42:19,490 INFO [Http11Protocol] Initializing Coyote HTTP/1.1 on http-0.0.0.0-8080
      12:42:19,490 INFO [AjpProtocol] Initializing Coyote AJP/1.3 on ajp-0.0.0.0-8009
      12:42:19,533 INFO [StandardService] Starting service jboss.web
      12:42:19,578 INFO [StandardEngine] Starting Servlet Engine: JBoss Web/2.1.3.GA
      12:42:19,727 INFO [Catalina] Server startup in 236 ms
      12:42:19,748 INFO [TomcatDeployment] deploy, ctxPath=/invoker
      12:42:20,556 INFO [RARDeployment] Required license terms exist, view vfszip:/opt/jboss-5.1.0.GA/server/web/deploy/jboss-local-jdbc.rar/META-INF/ra.xml
      12:42:20,565 INFO [RARDeployment] Required license terms exist, view vfszip:/opt/jboss-5.1.0.GA/server/web/deploy/jboss-xa-jdbc.rar/META-INF/ra.xml
      12:42:21,026 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=DefaultDS' to JNDI name 'java:DefaultDS'
      12:42:21,082 INFO [TomcatDeployment] deploy, ctxPath=/
      12:42:21,148 INFO [TomcatDeployment] deploy, ctxPath=/jmx-console
      12:42:21,252 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-0.0.0.0-8080
      12:42:21,350 INFO [AjpProtocol] Starting Coyote AJP/1.3 on ajp-0.0.0.0-8009
      12:42:21,354 INFO [ServerImpl] JBoss (Microcontainer) [5.1.0.GA (build: SVNTag=JBoss_5_1_0_GA date=200905221634)] Started in 19s:452ms
      12:48:29,956 INFO [ServerImpl] Runtime shutdown hook called, forceHalt: true
      12:48:29,957 INFO [Http11Protocol] Pausing Coyote HTTP/1.1 on http-0.0.0.0-8080
      12:48:29,984 INFO [Http11Protocol] Stopping Coyote HTTP/1.1 on http-0.0.0.0-8080
      12:48:30,003 INFO [AjpProtocol] Pausing Coyote AJP/1.3 on ajp-0.0.0.0-8009
      12:48:30,004 INFO [AjpProtocol] Stopping Coyote AJP/1.3 on ajp-0.0.0.0-8009
      12:48:30,014 INFO [TomcatDeployment] undeploy, ctxPath=/invoker
      12:48:30,102 INFO [TomcatDeployment] undeploy, ctxPath=/
      12:48:30,105 INFO [TomcatDeployment] undeploy, ctxPath=/jmx-console
      12:48:30,110 INFO [StandardService] Stopping service jboss.web
      12:48:30,152 INFO [ConnectionFactoryBindingService] Unbound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=DefaultDS' from JNDI name 'java:DefaultDS'
      12:48:30,235 INFO [TransactionManagerService] Stopping transaction recovery manager
      12:48:30,237 INFO [TransactionManagerService] Destroying TransactionManagerService
      12:48:30,386 INFO [HypersonicDatabase] Database standalone closed clean
      ^C^C12:48:31,882 INFO [ServerImpl] Shutdown complete
      



        • 1. Re: Linux UI Hangs with App Server Running
          Peter Johnson Master

          Looks like you are using the Sun JVM that Ubuntu provides. Personally, I would download the JVM from Sun's web site and install it and use it.

          Have you looked on Sun's web site to see if any issues have been posted regarding the JVM is this newer version of the kernel? Often, when a new OS level comes out, there will be patches in the JVM to "fix" problems. That is one of the things you have to put up with when using beta OSes.