1 Reply Latest reply on Mar 20, 2015 8:40 AM by Jeff Mesnil

    HornetQ clustering SECURITY_EXCEPTION on start up: jms-user

    Craig Jones Newbie

      HI,

       

      I have been following the approach to configure Wildfly in domain mode and also cluster HornetQ. All seemed to be going fine but when i started up the master (domain controller) server i received the following errors in the log over and over:

       

      [Server:server-one] 11:49:48,867 ERROR [org.hornetq.core.server] (default I/O-2) HQ224018: Failed to create session: HornetQSecurityException[errorType=SECURITY_EXCEPTION message=HQ119031: Unable to validate user: jms-user]

       

      I am using the full-ha profile from the domain.xml and configured it for the time being to be <security-enabled>false<security-enabled> as it seems to be the only way i can get the server to start up without this error message.

       

      I have also tried setting the <cluster-password> to something new, as suggested in blogs, etc., but still get the same error.

       

      What seems strange is that no-one else who has had this error mentions 'jms-user'. Most queries mention the being null but not jms-user.

       

      Also i cant find any reference in any of the files in the domain folder that mentions jms-user (by grepping for the string).

       

      Does anyone know how i can solve this issue? Or where i should define the user?