4 Replies Latest reply on May 1, 2015 6:13 PM by Tony Ayres

    WLP Managed Container error - WELD-000817: Unable to find Bean Deployment Archive

    Tony Ayres Newbie

      I'm trying to get the WLP managed container working on the latest Liberty Profile beta release .

       

      The CDI injection test fails with this error.

      [23/03/15 12:46:37:426 GMT] 00000025 com.ibm.ws.app.manager.AppMessageHelper I CWWKZ0018I: Starting application test.
      [23/03/15 12:46:37:784 GMT] 00000025 org.jboss.weld.Version I WELD-000900: SNAPSHOT
      [23/03/15 12:46:38:290 GMT] 00000025 com.ibm.ws.logging.internal.impl.IncidentImpl I FFDC1015I: An FFDC Incident has been created: "org.jboss.weld.exceptions.IllegalStateException: WELD-000817:
           Unable to find Bean Deployment Archive for class org.jboss.arquillian.testenricher.cdi.container.CDIExtension com.ibm.ws.container.service.state.internal.ApplicationStateManager 32" at ffdc_15.03.23_12.46.38.0.log
      [23/03/15 12:46:38:335 GMT] 00000025 com.ibm.ws.logging.internal.impl.IncidentImpl I FFDC1015I: An FFDC Incident has been created: "com.ibm.ws.container.service.state.StateChangeException:
           org.jboss.weld.exceptions.IllegalStateException: WELD-000817: Unable to find Bean Deployment Archive for class org.jboss.arquillian.testenricher.cdi.container.CDIExtension
            com.ibm.ws.app.manager.module.internal.DeployedAppInfoBase 496" at ffdc_15.03.23_12.46.38.1.log
      [23/03/15 12:46:38:337 GMT] 00000025 com.ibm.ws.app.manager.AppMessageHelper E CWWKZ0002E: An exception occurred while starting the application test.
           The exception message was: com.ibm.ws.container.service.state.StateChangeException: org.jboss.weld.exceptions.IllegalStateException: WELD-000817: Unable to find Bean Deployment Archive for
           class org.jboss.arquillian.testenricher.cdi.container.CDIExtension
      
      
      And the FFDC log...
      
      Exception = org.jboss.weld.exceptions.IllegalStateException
      Source = com.ibm.ws.container.service.state.internal.ApplicationStateManager
      probeid = 32
      Stack Dump = org.jboss.weld.exceptions.IllegalStateException: WELD-000817: Unable to find Bean Deployment Archive for class org.jboss.arquillian.testenricher.cdi.container.CDIExtension
              at org.jboss.weld.util.DeploymentStructures.getOrCreateBeanDeployment(DeploymentStructures.java:39)
              at org.jboss.weld.bootstrap.ExtensionBeanDeployer.deployBeans(ExtensionBeanDeployer.java:73)
              at org.jboss.weld.bootstrap.WeldStartup.startInitialization(WeldStartup.java:349)
              at org.jboss.weld.bootstrap.WeldBootstrap.startInitialization(WeldBootstrap.java:76)
              at com.ibm.ws.cdi.services.CDIComponentImpl.applicationStarting(CDIComponentImpl.java:104)
              at com.ibm.ws.container.service.state.internal.ApplicationStateManager.fireStarting(ApplicationStateManager.java:29)
              at com.ibm.ws.container.service.state.internal.StateChangeServiceImpl.fireApplicationStarting(StateChangeServiceImpl.java:51)
              at com.ibm.ws.app.manager.module.internal.DeployedAppInfoBase.preDeployApp(DeployedAppInfoBase.java:495)
              at com.ibm.ws.app.manager.module.internal.DeployedAppInfoBase.deployApp(DeployedAppInfoBase.java:522)
              at com.ibm.ws.app.manager.war.internal.WARApplicationHandlerImpl.install(WARApplicationHandlerImpl.java:80)
              at com.ibm.ws.app.manager.internal.statemachine.StartAction.execute(StartAction.java:139)
              at com.ibm.ws.app.manager.internal.statemachine.ApplicationStateMachineImpl.enterState(ApplicationStateMachineImpl.java:1166)
              at com.ibm.ws.app.manager.internal.statemachine.ApplicationStateMachineImpl.performAction(ApplicationStateMachineImpl.java:1012)
              at com.ibm.ws.app.manager.internal.statemachine.ApplicationStateMachineImpl.run(ApplicationStateMachineImpl.java:787)
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
              at java.lang.Thread.run(Thread.java:722)
      
      

       

       

       

      This worked with the previous versions of WLP we tested on -  8.5.5.3 and 8.5.5.4 - so I'm thinking this is something in the app server thats changed. (I have seen some other issues with the CDI features of this beta) I have tried swapping around Arquillian versions - no improvement with  1.1.3, 1.1.4, 1.1.5 and 1.1.6.

       

      I'm going to chase this with IBM, but is there anything else on the Arquillian end that I could try out to work around this? (I'm assuming it might take a while to get a fix for this from IBM)