0 Replies Latest reply on Mar 24, 2015 6:58 PM by Shawn Altman

    Missing Dependents: Data-Source 6.2

    Shawn Altman Newbie

      Hi All;

       

      Looking for some help with a data-source error. I am migrating a 5.1 JBOSS application to a 6.2 JBOSS application. After spending a couple days online learning how to configure JBOSS 6.2 I am getting the below error. Migration to JBOSS 6.2 is required by our team. I have tried several different ways to configure the XML. I have tried the module vs placing the .jar in deploy folder.

       

      My current set up is as follows:

       

      ojdbc14.jar is in deploy folder

       

      I have updated the standalone.xml as below:

      <datasources>
      <datasource jndi-name="java:/jdbc/CCASDataSource"
      pool-name="CCASDataSource"
      enabled="true"
      use-java-context="true">
      <connection-url>jdbc:oracle:thin:@##########:1521:########</connection-url>
      <driver>oracle</driver>
      <pool>
      <min-pool-size>1</min-pool-size>
      <max-pool-size>20</max-pool-size>
      </pool>
      <security>
      <user-name>######</user-name>
      <password>###### </password>
      </security>
      </datasource>   
      </datasources>  

       

      Error is below in bold:

       

      15:00:41,684 INFO  [org.jboss.modules] (main) JBoss Modules version 1.3.0.Final-redhat-2

      15:00:42,089 INFO  [org.jboss.msc] (main) JBoss MSC version 1.0.4.GA-redhat-1

      15:00:42,151 INFO  [org.jboss.as] (MSC service thread 1-6) JBAS015899: JBoss EAP 6.2.0.GA (AS 7.3.0.Final-redhat-14) starting

      15:00:43,381 INFO  [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015003: Found ccas.ear in deployment directory. To trigger deployment create a file called ccas.ear.dodeploy

      15:00:43,403 INFO  [org.xnio] (MSC service thread 1-3) XNIO Version 3.0.7.GA-redhat-1

      15:00:43,404 INFO  [org.jboss.as.server] (Controller Boot Thread) JBAS015888: Creating http management service using socket-binding (management-http)

      15:00:43,410 INFO  [org.xnio.nio] (MSC service thread 1-3) XNIO NIO Implementation Version 3.0.7.GA-redhat-1

      15:00:43,417 INFO  [org.jboss.remoting] (MSC service thread 1-3) JBoss Remoting version 3.2.18.GA-redhat-1

      15:00:43,470 INFO  [org.jboss.as.security] (ServerService Thread Pool -- 42) JBAS013171: Activating Security Subsystem

      15:00:43,475 INFO  [org.jboss.as.naming] (ServerService Thread Pool -- 37) JBAS011800: Activating Naming Subsystem

      15:00:43,490 INFO  [org.jboss.as.webservices] (ServerService Thread Pool -- 46) JBAS015537: Activating WebServices Extension

      15:00:43,500 INFO  [org.jboss.as.security] (MSC service thread 1-5) JBAS013170: Current PicketBox version=4.0.19.SP2-redhat-1

      15:00:43,504 INFO  [org.jboss.as.jsf] (ServerService Thread Pool -- 35) JBAS012605: Activated the following JSF Implementations: [main, 1.2]

      15:00:43,520 INFO  [org.jboss.as.clustering.infinispan] (ServerService Thread Pool -- 29) JBAS010280: Activating Infinispan subsystem.

      15:00:43,523 INFO  [org.jboss.as.naming] (MSC service thread 1-1) JBAS011802: Starting Naming Service

      15:00:43,566 INFO  [org.jboss.as.connector.logging] (MSC service thread 1-6) JBAS010408: Starting JCA Subsystem (IronJacamar 1.0.23.Final-redhat-1)

      15:00:43,582 INFO  [org.jboss.as.mail.extension] (MSC service thread 1-5) JBAS015400: Bound mail session [java:jboss/mail/Default]

      15:00:44,281 INFO  [org.jboss.ws.common.management] (MSC service thread 1-1) JBWS022052: Starting JBoss Web Services - Stack CXF Server 4.2.3.Final-redhat-1

      15:00:44,301 INFO  [org.jboss.as.server.deployment.scanner] (MSC service thread 1-3) JBAS015012: Started FileSystemDeploymentService for directory C:\jboss-eap-6.2_CCAS\standalone\deployments

      15:00:44,307 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "ccas.ear" (runtime-name: "ccas.ear")

      15:00:44,308 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-3) JBAS015876: Starting deployment of "ojdbc14.jar" (runtime-name: "ojdbc14.jar")

      15:00:44,367 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "null" (runtime-name: "ccas.war")

      15:00:44,412 INFO  [org.jboss.as.remoting] (MSC service thread 1-7) JBAS017100: Listening on 127.0.0.1:9999

      15:00:44,416 INFO  [org.jboss.as.remoting] (MSC service thread 1-8) JBAS017100: Listening on 127.0.0.1:4447

      15:00:44,454 INFO  [org.apache.coyote.http11] (MSC service thread 1-6) JBWEB003001: Coyote HTTP/1.1 initializing on : http-dev.mytest.com/127.0.0.1:8080

      15:00:44,491 INFO  [org.apache.coyote.http11] (MSC service thread 1-6) JBWEB003000: Coyote HTTP/1.1 starting on: http-dev.mytest.com/127.0.0.1:8080

      15:00:44,942 INFO  [org.infinispan.factories.GlobalComponentRegistry] (ServerService Thread Pool -- 65) ISPN000128: Infinispan version: Infinispan 'Delirium' 5.2.7.Final

      15:00:44,986 INFO  [org.infinispan.factories.TransactionManagerFactory] (ServerService Thread Pool -- 65) ISPN000161: Using a batchMode transaction manager

      15:00:44,987 INFO  [org.infinispan.factories.TransactionManagerFactory] (ServerService Thread Pool -- 67) ISPN000161: Using a batchMode transaction manager

      15:00:45,168 INFO  [org.infinispan.jmx.CacheJmxRegistration] (ServerService Thread Pool -- 65) ISPN000031: MBeans were successfully registered to the platform MBean server.

      15:00:45,169 INFO  [org.infinispan.jmx.CacheJmxRegistration] (ServerService Thread Pool -- 67) ISPN000031: MBeans were successfully registered to the platform MBean server.

      15:00:45,170 INFO  [org.jboss.as.clustering.infinispan] (ServerService Thread Pool -- 65) JBAS010281: Started local-web cache from web container

      15:00:45,172 INFO  [org.jboss.as.clustering.infinispan] (ServerService Thread Pool -- 67) JBAS010281: Started default-host/ccas cache from web container

      15:00:45,182 INFO  [org.jboss.web] (ServerService Thread Pool -- 67) JBAS018210: Register web context: /ccas

      15:00:45,748 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 26) JBAS018559: Deployed "ojdbc14.jar" (runtime-name : "ojdbc14.jar")

      15:00:45,748 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 26) JBAS018559: Deployed "ccas.ear" (runtime-name : "ccas.ear")

      15:00:45,749 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report

      JBAS014775:    New missing/unsatisfied dependencies:

            service jboss.jdbc-driver.oracle (missing) dependents: [service jboss.data-source.java:/jdbc/CCASDataSource, service jboss.driver-demander.java:/jdbc/CCASDataSource]

       

      15:00:45,811 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management

      15:00:45,811 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990

      15:00:45,812 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss EAP 6.2.0.GA (AS 7.3.0.Final-redhat-14) started (with errors) in 4518ms - Started 360 of 430 services (3 services failed or missing dependencies, 66 services are passive or on-demand)