1 Reply Latest reply on Mar 25, 2015 2:34 PM by jaikiran pai

    Strange error when trying to deploy to Wildfly 8.2.0 final

    Anton Hughes Master

      I'm trying to deploy an Errai application to Jboss Wildfly 8.2.0 Final, however, I am getting the following deployment error.

       

       

      Caused by: java.lang.ClassNotFoundException: org.apache.catalina.core.ApplicationContextFacade from [Module "deployment.app.ui-1.8.2.war:main" from Service Module Loader]

          at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:213) [jboss-modules.jar:1.3.3.Final]

          at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:459) [jboss-modules.jar:1.3.3.Final]

          at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:408) [jboss-modules.jar:1.3.3.Final]

          at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:389) [jboss-modules.jar:1.3.3.Final]

          at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:134) [jboss-modules.jar:1.3.3.Final]

          ... 13 more

       

       

      2015-03-25 13:05:39,466 ERROR [org.jboss.as.controller.management-operation] (management-handler-thread - 1) JBAS014613: Operation ("deploy") failed - address: ([("deployment" => "app.ui-1.8.2.war")]) - failure description: {"JBAS014671: Failed services" => {"jboss.undertow.deployment.default-server.default-host./" => "org.jboss.msc.service.StartException in service jboss.undertow.deployment.default-server.default-host./: Failed to start service

          Caused by: java.lang.NoClassDefFoundError: org/apache/catalina/core/ApplicationContextFacade

          Caused by: java.lang.ClassNotFoundException: org.apache.catalina.core.ApplicationContextFacade from [Module \"deployment.app.ui-1.8.2.war:main\" from Service Module Loader]"}}

      2015-03-25 13:05:39,468 ERROR [org.jboss.as.server] (management-handler-thread - 1) JBAS015870: Deploy of deployment "app.ui-1.8.2.war" was rolled back with the following failure message:

      {"JBAS014671: Failed services" => {"jboss.undertow.deployment.default-server.default-host./" => "org.jboss.msc.service.StartException in service jboss.undertow.deployment.default-server.default-host./: Failed to start service

          Caused by: java.lang.NoClassDefFoundError: org/apache/catalina/core/ApplicationContextFacade

          Caused by: java.lang.ClassNotFoundException: org.apache.catalina.core.ApplicationContextFacade from [Module \"deployment.app.ui-1.8.2.war:main\" from Service Module Loader]"}}

      It appears as if Weld incorrectly detects the application server as Tomcat.

       

       

      Any ideas as to what might be wrong?