0 Replies Latest reply on Sep 14, 2009 4:41 AM by Steven Edgar

    Intermittent

    Steven Edgar Newbie

      We've got an odd issue going on. Every so often on startup one or more of our Jboss JVMs throws an error like

      2009-09-14 06:12:47,438 INFO [org.jboss.ejb.EjbModule] Deploying ClasspathSession
      2009-09-14 06:12:47,495 INFO [org.jboss.ejb.plugins.local.BaseLocalProxyFactory] Bound EJB LocalHome 'ClasspathSession' to jndi 'loc
      al/ClasspathSession@17678065'
      2009-09-14 06:12:47,501 INFO [org.jboss.ejb.EJBDeployer] Deployed: file:/opt/jboss/current/server/ps2/tmp/deploy/tmp2105frontend-clu
      stered.ear-contents/atg_bootstrap_ejb.jar
      2009-09-14 06:12:47,615 INFO [org.jboss.deployment.EARDeployer] Started J2EE application: file:/opt/jboss/current/server/ps2/deploy/
      frontend-clustered.ear
      2009-09-14 06:12:47,846 ERROR [org.jboss.deployment.scanner.URLDeploymentScanner] Incomplete Deployment listing:
      
      --- Packages waiting for a deployer ---
      org.jboss.deployment.DeploymentInfo@2d6e122c { url=file:/opt/jboss/current/server/ps2/deploy/httpha-invoker.sar/invoker.war/ }
       deployer: null
       status: Starting
       state: INIT_WAITING_DEPLOYER
       watch: file:/opt/jboss/current/server/ps2/deploy/httpha-invoker.sar/invoker.war/
       altDD: null
       lastDeployed: 1252905153422
       lastModified: 1240146078000
       mbeans:
      ...
      ..A number of other packages are also listed in this state
      ....
      
      


      Re-starting the jvm clears the problem. There are no deploys going on at the time, the ear file is identical on both starts. We are using the org.jboss.ha.framework and TreeCache, which are about the only things having started prior to this error, and these generally come up ok when we get this issue.

      JBoss [Zion] 4.0.5.GA
      Java version: 1.5.0_16,Sun Microsystems Inc.
      OS-System: Linux 2.6.9-67.ELhugemem,i386 (RedHat ES 4)