4 Replies Latest reply on Apr 12, 2015 11:46 PM by valsaraj viswanathan

    SecurityException: Cannot verify bcprov-jdk16-140.jar!

    valsaraj viswanathan Master

      Hi,

       

      I am getting following exception when running my application in WildFly-8.2. This was working fine with JBoss-4.2.2.GA.

      Caused by: java.lang.SecurityException: JCE cannot authenticate the provider BC

      at javax.crypto.Cipher.getInstance(Cipher.java:642) [jce.jar:1.7.0_10]

      at javax.crypto.Cipher.getInstance(Cipher.java:580) [jce.jar:1.7.0_10]

      at org.bouncycastle.openpgp.PGPEncryptedDataGenerator$PubMethod.addSessionInfo(Unknown Source) [bcpg-jdk15-140.jar:1.40.0]

      ... 48 more

      Caused by: java.lang.SecurityException: Cannot verify jar:vfs:/content/app.ear/lib/bcprov-jdk16-140.jar!/

       

      What is the solution to fix this?

       

      Thanks!