3 Replies Latest reply on Apr 14, 2015 12:30 AM by Mike Brooks

    Wildfly Microsoft SQL Server XA datasource connection failed

    Mike Brooks Newbie

      I am trying to configure a microsoft sql server XA datasource connection.  When in the admin console and I do a test connection it fails and I get the following in the server.log

       

      015-04-08 09:51:53,295 FINE  [com.microsoft.sqlserver.jdbc.internals.SQLServerConnection] (XNIO-1 task-10) ConnectionID:4 This attempt No: 0

      2015-04-08 09:51:53,295 FINE  [com.microsoft.sqlserver.jdbc.internals.SQLServerConnection] (XNIO-1 task-10) ConnectionID:4 Connecting with server: localhost port: 1433 Timeout slice: 15000 Timeout Full: 15

      2015-04-08 09:51:53,295 FINE  [com.microsoft.sqlserver.jdbc.internals.SQLServerConnection] (XNIO-1 task-10) ConnectionID:4 ClientConnectionId: 529a3226-eaea-4c4d-8db1-86d0e3e42214 Server returned major version:12

      2015-04-08 09:51:53,295 FINE  [com.microsoft.sqlserver.jdbc.internals.XA] (XNIO-1 task-10) SQLServerXADataSource:1 End get physical connection, ConnectionID:3 ClientConnectionId: 50343aa0-9324-4516-8480-2859cba4aea1

      2015-04-08 09:51:53,295 FINE  [com.microsoft.sqlserver.jdbc.internals.SQLServerDataSource] (XNIO-1 task-10) SQLServerXAConnection:2 Physical connection, ConnectionID:3 ClientConnectionId: 50343aa0-9324-4516-8480-2859cba4aea1

      2015-04-08 09:51:53,295 FINE  [com.microsoft.sqlserver.jdbc.internals.SQLServerDataSource] (XNIO-1 task-10) SQLServerXAConnection:2 proxy  ProxyConnectionID:2 is returned.

      2015-04-08 09:51:53,295 FINE  [com.microsoft.sqlserver.jdbc.internals.SQLServerStatement] (XNIO-1 task-10) SQLServerStatement:2 created by (ConnectionID:3 ClientConnectionId: 50343aa0-9324-4516-8480-2859cba4aea1)

      2015-04-08 09:51:53,295 FINE  [com.microsoft.sqlserver.jdbc.internals.SQLServerStatement] (XNIO-1 task-10) SQLServerStatement:2 Executing (not server cursor) jdbc:sqlserver://localhost:1433;databaseName=MyBills_db

      2015-04-08 09:51:53,295 FINE  [com.microsoft.sqlserver.jdbc.internals.SQLServerException] (XNIO-1 task-10) *** SQLException: com.microsoft.sqlserver.jdbc.SQLServerException: Incorrect syntax near '/'. Msg 102, Level 15, State 1, Incorrect syntax near '/'.

      2015-04-08 09:51:53,295 WARN  [org.jboss.jca.core.connectionmanager.pool.strategy.OnePool] (XNIO-1 task-10) IJ000604: Throwable while attempting to get a new connection: null: javax.resource.ResourceException: Could not create connection

          at org.jboss.jca.adapters.jdbc.xa.XAManagedConnectionFactory.getXAManagedConnection(XAManagedConnectionFactory.java:524) [ironjacamar-jdbc-1.1.9.Final.jar:1.1.9.Final]

          at org.jboss.jca.adapters.jdbc.xa.XAManagedConnectionFactory.createManagedConnection(XAManagedConnectionFactory.java:433) [ironjacamar-jdbc-1.1.9.Final.jar:1.1.9.Final]

          at org.jboss.jca.core.connectionmanager.pool.mcp.SemaphoreArrayListManagedConnectionPool.createConnectionEventListener(SemaphoreArrayListManagedConnectionPool.java:1166) [ironjacamar-core-impl-1.1.9.Final.jar:1.1.9.Final]

          at org.jboss.jca.core.connectionmanager.pool.mcp.SemaphoreArrayListManagedConnectionPool.getConnection(SemaphoreArrayListManagedConnectionPool.java:446) [ironjacamar-core-impl-1.1.9.Final.jar:1.1.9.Final]

          at org.jboss.jca.core.connectionmanager.pool.AbstractPool.internalTestConnection(AbstractPool.java:764) [ironjacamar-core-impl-1.1.9.Final.jar:1.1.9.Final]

       

      The syntax bolded above looks correct to me; although I have gone bug-eyed looking at it.  Can anyone tell me what the issue is?  Thanks in advance.