3 Replies Latest reply on Apr 13, 2015 5:01 PM by Christopher Halbersma

    Mod_Cluster + Wildfly Domain Question

    Christopher Halbersma Newbie

      We are using wildfly in domain mode (8.1.0.Final) and mod_cluster (1.2.0.Final). Our architecture has 1 slave and 1 master behind 1 load Apache+mod_cluster load balancer. Looks something like this:

      client ---- Request for app?wsdl fails ------
             |                                     |
          conns to slv & mas                       |
          for app?wsdl work                      +----+
             |                                   | lb |
             |                                   +----+
             |_____________   ____________________|  |
                           |  |                      | 
                         +----+                      | 
                         | mas|                  +----+
                         +----+                  | slv|
                                                 +----+
      

      (I have a visio and an svg of this basic diagram if needed).

       

      When we do a request for the wsdl file through the mod_cluster load balancer we get a 503 error (Service Temporarily Unavailable).  However when we go directly to one of the nodes (either master or slave) it works. Additionally the rest of the soap service is working. We think the error might be related to this issue. However we tried to add the rewrite rule to and it didn't really work. It's possible we added the rewrite rule wrong. But before I go changing every setting on mod_cluster I was hoping to get some confirmation that I hadn't missed anything obscenely obvious.

       

      Message was edited by: Christopher Halbersma ASCII Stuff broke

        • 1. Re: Mod_Cluster + Wildfly Domain Question
          Rituraj Sinha Novice

          can you give the details about your apache setup as what are the rewrite rules you are applying and the modcluster setup as well how have you defined it ..

          also what happens when you comment out the rewrite rule?
          are you able to see the nodes connected to modcluster when you do on the status page http://hostname(webserver):port/mod_cluster-manager

           

          -Rituraj

          • 2. Re: Mod_Cluster + Wildfly Domain Question
            Christopher Halbersma Newbie

            Sorry for the delay.

            can you give the details about your apache setup as what are the rewrite rules you are applying and the modcluster setup as well how have you defined it ..

            My rewrite rule that we tried (my app is called warranty-ws) based on the site.

            ProxyPass /warranty-ws balancer://mycluster/warranty-ws stickysession=JSESSIONID|jsessionid nofailover=On

            ProxyPassReverse /warranty-ws balancer://mycluster/warranty-ws

            When we enable this it just changes the response from a 503 error to 404 not found error.

            also what happens when you comment out the rewrite rule?

            I've left if off for a while. But the app works normally it's just my warranty-ws?wsdl request that won't forward. The rest of the SOAP service seems to work as expected.

            For clarification we don't have a rewrite rule in our current httpd.conf. The error just seemed similar to what we were seeing.

            are you able to see the nodes connected to modcluster when you do on the status page http://hostname(webserver):port/mod_cluster-manager

            Yes I see both my nodes connected when I look at the status page. And when we do load testing we see both apps being connected to in the log files.

            CRH

            • 3. Re: Mod_Cluster + Wildfly Domain Question
              Christopher Halbersma Newbie

              Rituraj,

              I believe I found the root cause. Here's the RHEL page on it. The quick fix using app/?wsdl works and is a better workaround than what we had been subscribing.

              The list workaround with my application:

              RewriteEngine On RewriteRule ^/warranty-ws$ /warranty-ws/ [R,L] 

              Doesn't seem to fix the issue. I believe the answer here is to upgrade to mod_cluster 1.2.4+. There may be a short term issue that helps to fix my problem I'll have to take a look at rewrite rules in apache.

              Thank you very much for your assistance.

              CRH