1 Reply Latest reply on Apr 16, 2015 10:54 AM by Fernando Panci

    RichFaces 4.5 - Weblogic 11g - ReferenceError

    Fernando Panci Newbie

      Hi, I'm working on an application using Struts and JSF 2 with RichFaces 4.5.4.

       

      Everything works fine when the application runs on a Tomcat (7) server.

      But when I run it on a WebLogic (11gR1-10.3.6) server the JS resources are not loaded.

       

      The rich:popupPanel gets the error: ReferenceError: RichFaces is not defined

      And when I try to run a jQuery script I get: ReferenceError: jQuery is not defined

       

      There are specific requirements on running RichFaces on Weblogic?

       

      (I'm using <h:head> instead of <head>)

       

      We use Weblogic in our production environment. I appreciate any help.

        • 1. Re: RichFaces 4.5 - Weblogic 11g - ReferenceError
          Fernando Panci Newbie

          Well, it seems that ResourceServlet wasn't automatically registered.

          As explains here ResourceServlet is automatically registered in the Servlet 3.0 and higher environments.

          In the Servlet 2.5 and lower environments, it is necessary to register the ResourceServlet manually in the WEB-INF/web.xml configuration file:

           

              <servlet>

                  <servlet-name>Resource Servlet</servlet-name>

                  <servlet-class>org.richfaces.webapp.ResourceServlet</servlet-class>

                  <load-on-startup>1</load-on-startup>

              </servlet>

              <servlet-mapping>

                  <servlet-name>Resource Servlet</servlet-name>

                  <url-pattern>/org.richfaces.resources/*</url-pattern>

              </servlet-mapping>

              <context-param>

                  <param-name>org.richfaces.resourceOptimization.enabled</param-name>

                  <param-value>true</param-value>

              </context-param>