2 Replies Latest reply on Apr 20, 2015 3:58 AM by Fredrik Bodin

    Error using nodes with jboss.bind.address:127.0.0.1

    Fredrik Bodin Newbie

      Hi

       

      I want to use the jboss.bind.address:127.0.0.1 on all my JBoss 8.2 nodes connecting to the modcluster.

      But when a take down a node in the modcluster, its stops working and the following error occurs.

       

      Note: Everything works when I am using the "hostip" as jboss.bind.address (164.135.92.65, 164.135.92.66)

       

      Fri Apr 17 11:21:39 2015] [debug] mod_manager.c(1910): manager_trans STATUS

      [Fri Apr 17 11:21:39 2015] [debug] mod_manager.c(2618): manager_handler STATUS processing: "JVMRoute=L7700706-wildfly02&Load=100"

      [Fri Apr 17 11:21:39 2015] [debug] mod_manager.c(1625): Processing STATUS

      [Fri Apr 17 11:21:39 2015] [debug] proxy_util.c(1964): proxy: ajp: retrying the worker for (127.0.0.1)

      [Fri Apr 17 11:21:39 2015] [debug] proxy_util.c(1970): proxy: ajp: worker for (127.0.0.1) has been marked for retry

      [Fri Apr 17 11:21:39 2015] [debug] proxy_util.c(2026): proxy: ajp: has acquired connection for (127.0.0.1)

      [Fri Apr 17 11:21:39 2015] [debug] proxy_util.c(2082): proxy: connecting ajp://127.0.0.1:8209/ to 127.0.0.1:8209

      [Fri Apr 17 11:21:39 2015] [debug] proxy_util.c(2209): proxy: connected / to 127.0.0.1:8209

      [Fri Apr 17 11:21:39 2015] [debug] proxy_util.c(2460): proxy: ajp: fam 2 socket created to connect to 127.0.0.1

      [Fri Apr 17 11:21:39 2015] [error] (111)Connection refused: proxy: ajp: attempt to connect to 127.0.0.1:8209 (127.0.0.1) failed

      [Fri Apr 17 11:21:39 2015] [error] ap_proxy_connect_backend disabling worker for (127.0.0.1)

      [Fri Apr 17 11:21:39 2015] [debug] mod_proxy_cluster.c(1361): proxy_cluster_try_pingpong: can't connect to backend

      [Fri Apr 17 11:21:39 2015] [debug] proxy_util.c(2044): proxy: ajp: has released connection for (127.0.0.1)

      [Fri Apr 17 11:21:39 2015] [debug] mod_proxy_cluster.c(2331): proxy_cluster_isup: pingpong ajp://127.0.0.1:8209/ failed

      [Fri Apr 17 11:21:39 2015] [debug] mod_manager.c(2667): manager_handler STATUS  OK

      [Fri Apr 17 11:21:39 2015] [error] proxy: CLUSTER: (balancer://wildfly02). All workers are in error state

      [Fri Apr 17 11:21:39 2015] [error] proxy: CLUSTER: (balancer://wildfly02). All workers are in error state

       

      mod_cluster_manager

      LBGroup wildfly02: Enable Nodes Disable Nodes

       

      Node L7700705-wildfly02 (ajp://127.0.0.1:8209):

       

      Enable Contexts Disable Contexts

      Balancer: wildfly02,LBGroup: wildfly02,Flushpackets: Off,Flushwait: 10000,Ping: 10000000,Smax: 100,Ttl: 600000000,Status: OK,Elected: 822,Read: 77907649,Transferred: 370722,Connected: 0,Load: 9

      Virtual Host 1:

       

      Contexts:

       

      /app/web, Status: ENABLED Request: 0 Disable

      /app/ws, Status: ENABLED Request: -1 Disable

      Aliases:

       

      localhost

      default-host

      Node L7700706-wildfly02 (ajp://127.0.0.1:8209):

       

      Enable Contexts Disable Contexts

      Balancer: wildfly02,LBGroup: wildfly02,Flushpackets: Off,Flushwait: 10000,Ping: 10000000,Smax: 100,Ttl: 600000000,Status: OK,Elected: 4954,Read: 468942147,Transferred: 2234254,Connected: 1,Load: 73

      Virtual Host 1:

       

      Contexts:

       

      /app/ws, Status: ENABLED Request: 1 Disable

      /app/web, Status: ENABLED Request: 0 Disable

      Aliases:

       

      localhost

      default-host

       

      Quick config summary

      Two nodes, where each node has a httpd front-end and a JBoss Wildfly 8.2 server with the application deployed.


      Installed RPM:s

        httpd-tools-2.2.15-39.el6.x86_64

        httpd_mod_cluster-1.2.6-1.noarch

        httpd-2.2.15-39.el6.x86_64

       

      /etc/httpd/conf.d/mod_cluster.conf

        # Load mod_cluster modules

        LoadModule slotmem_module /etc/httpd/modules/mod_slotmem.so

        LoadModule manager_module /etc/httpd/modules/mod_manager.so

        LoadModule proxy_cluster_module /etc/httpd/modules/mod_proxy_cluster.so

        LoadModule advertise_module /etc/httpd/modules/mod_advertise.so

        MemManagerFile /var/cache/mod_cluster

        # Virtualhost for Wildfly mod_cluster

        Listen 164.135.92.65:6666

        <VirtualHost 164.135.92.65:6666 >

        <Directory />

           Order deny,allow

           Deny from all

            Allow from all

         </Directory>

         LogLevel debug

         ServerAdvertise Off

         EnableMCPMReceive

         KeepAliveTimeout 60

         MaxKeepAliveRequests 0

        </VirtualHost>

       

      /etc/httpd/conf.d/app.conf

        <VirtualHost 164.135.92.65:80>

        ServerName app.abc.se

       

        KeepAliveTimeout 60

        MaxKeepAliveRequests 0

        AllowDisplay On

       

        <Location /mod_cluster_manager>

         SetHandler mod_cluster-manager

         Order deny,allow

         Deny from all

         Allow from all

        </Location>

        </VirtualHost>

       

      JBoss 8.2 (two nodes L7700705 & L7700706)

      <property name="jboss.bind.address" value="127.0.0.1"/>

      <property name="jboss.node.name" value="L7700705-wildfly02"/>

      <property name="jboss.node.name" value="L7700706-wildfly02"/>

      <property name="jboss.socket.binding.port-offset" value="200"/>

       

      <mod-cluster-config proxy-list="164.135.92.65:6666,164.135.92.66:6666" balancer="wildfly02" advertise="false" excluded-contexts="ROOT,invoker,jbossws,juddi,console,jolokia" auto-enable-contexts="true" sticky-session="true" sticky-session-remove="true" worker-timeout="1" max-attempts="3" smax="100" ttl="600" node-timeout="10" load-balancing-group="wildfly02" connector="ajp">

      <dynamic-load-provider>

                          <load-metric type="busyness"/>

                      </dynamic-load-provider>

                  </mod-cluster-config>

              </subsystem>

       

      Message was edited by: Fredrik Bodin