2 Replies Latest reply on Apr 27, 2015 7:45 AM by Chris Rankin

    WELD Servlet 2.2.x, javax.el and Tomcat 7

    Chris Rankin Novice

      Hi,

       

      I've been using WELD 2.2.x and Tomcat 7 successfully for a while now, but I've just noticed that WELD 2.2.x is asking for javax.el:javax.el-api:3.0.0. I've been using Tomcat 7's internal org.apache.tomcat:tomcat-el-api dependency instead via "provided" scope, but this only seems to be equivalent to javax.el:el-api:2.2.

       

      Is using EL-API 2.2 instead of 3.0 going to be a problem, please? I don't remember reading anything about this in the WELD 2.1 -> 2.2 upgrade notes. Do I need to ignore Tomcat 7's javax.el now and provide my own? Which "expressions" is this library being used for anyway? And is any of this even relevant to weld-servlet in the first place?

       

      Cheers,

      Chris

       

      P.S. Before upgrading to WELD 2.2, I was using weld-servlet 2.1.2.Final in Tomcat 7. And weld-core 2.1.2.Final also has a dependency on org.jboss.spec.javax.el:jboss-el-api_3.0_spec-1.0.0.Alpha1, despite being an implementation of CDI 1.1 which declares a dependency on javax.el:el-api 2.2. So I have no idea if weld-servlet 2.2.x's dependency on EL 3.0 is real, or whether someone is just putting arbitrary numbers in POMs.