1 Reply Latest reply on Apr 30, 2015 1:47 AM by James Livingston

    Classnotfoundexception with applets on wildfly wildfly-9.0.0.Alpha1 and wildfly-8.2.0.Final

    sud patt Newbie

      Hi,

       

      I have been trying to access an applet class in WEB-INF/classes from a JSF page and I am getting a ClassNotFoundException. I have tried most of the remedies provided in the documentation.Can somebody point me in the right direction to get this problem sorted out

       

      EAR->structure

           META-INF

                application.xml

                jboss-deployment-structure.xml

           EJB JAR file

           WAR file

      WAR->structure

           META-INF

           WEB-INF

                   classes

                   beans.xml

                   faces-config.xml

           index.html (refers to priceserverhome.XHTML)

           priceserverhome.xhtml

       

      My applet reference inside the priceserverhome.xhtml is given below. the applet class is in WEB-INF classes. I have also tried the following method and none works


      1) I tried compiling the applet as JAR file placed it in EAR root, tried referring from JSF in WAR using archive and code attribute of applet tag.).Changed jboss-deployment-structure.xml as stated in the documentation

      2) In addition I have tried tweeking web.xml to load a applet JAR from WAR

      3) Added Manifest.mf in WAR and specified the JAR in EAR root and EAR/lib


       

      <applet code="org.sud.ps.ticker.Ticker" height="200" width="200">
      </applet>


      I am attaching the jboss-deployment-structure and application.xml files. My understanding is any class in WEB-INF/classes within a WAR is accessible by JSF or JSP


      If possible please provide an working example with JSF referring to an applet class inside a WAR which is in an EAR or let me know what is wrong. I am referring to the application as http://localhost:8080/priceserver. when I do this the EJB class is recognised by JSF in WAR but accessing the applet in WEB-INF/classes throws an classnotfound exception


      Thanks and Regards

      Sudarsan