0 Replies Latest reply on Apr 21, 2006 2:17 AM by Manjith Kumar

    Strange Behaviour with JBoss using Cache and JCA

    Manjith Kumar Newbie

      Hi,

      I am using Hibernate 3.1, JBoss 4.0.2 and Oracle 10g as the Database.

      I am using JCA and Caching. I have implemented JBossCacheService for caching. I am experiencing a strange behaviour whenever the Jboss is started for every 1st request from my test JSP.Whichever method I have invoked is internally invoked as toString() instead of the actual method but from the 2nd and subsequent requests the method which is getting invoked is the same method whivh I have called from Jboss.
      I feel there is something wrong with my configurations.

      I have configured my oracle-xa-ds.xml as following : -

      <datasources>
       <ha-xa-datasource>
       <jndi-name>XAOracleDS</jndi-name>
       <use-java-context>false</use-java-context>
       <track-connection-by-tx/>
       <isSameRM-override-value>false</isSameRM-override-value>
       <xa-datasource-class>oracle.jdbc.xa.client.OracleXADataSource</xa-datasource-class>
       <xa-datasource-property name="URL">jdbc:oracle:thin:@localhost:1521:XE|jdbc:oracle:thin:@ip:1521:test</xa-datasource-property>
       <url-property>URL</url-property>
       <url-delimeter>|</url-delimeter>
       <xa-datasource-property name="User">test</xa-datasource-property>
       <xa-datasource-property name="Password">test</xa-datasource-property>
       <min-pool-size>1</min-pool-size>
       <max-pool-size>10</max-pool-size>
       <exception-sorter-class-name>org.jboss.resource.adapter.jdbc.vendor.OracleExceptionSorter</exception-sorter-class-name>
       <!-- <check-valid-connection-sql>"select count(*) from product"</check-valid-connection-sql> -->
       <!-- sql to call when connection is created -->
       <new-connection-sql>select count(*) from product</new-connection-sql>
      
       <metadata>
       <type-mapping>Oracle10g</type-mapping>
       </metadata>
       </ha-xa-datasource>
      
       <mbean code="org.jboss.resource.adapter.jdbc.vendor.OracleXAExceptionFormatter"
       name="jboss.jca:service=OracleXAExceptionFormatter">
       <depends optional-attribute-name="TransactionManagerService">jboss:service=TransactionManager</depends>
       </mbean>
      
      </datasources>


      My hibernate-cfg.xml is: -

      <?xml version='1.0' encoding='utf-8'?>
      <!DOCTYPE hibernate-configuration PUBLIC
       "-//Hibernate/Hibernate Configuration DTD 3.0//EN"
       "http://hibernate.sourceforge.net/hibernate-configuration-3.0.dtd">
      <hibernate-configuration>
      
       <!-- a SessionFactory instance listed as /jndi/name -->
       <session-factory>
      
       <!-- properties -->
      
       <property name="hibernate.cache.provider_class">org.hibernate.cache.TreeCacheProvider</property>
       <property name="hibernate.cache.use_query_cache">true</property>
       <property name="hibernate.cache.use_second_level_cache">true</property>
       <property name="hibernate.cache.use_minimal_puts">true</property>
       <property name="hibernate.cache.use_structured_entries">true</property>
       <property name="current_session_context_class">thread</property>
      
       <property name="show_sql">true</property>
       <property name="use_outer_join">true</property>
      
       <!-- mapping files -->
      
       <mapping resource="hibernate-config/com/dnaO2/infra/persistence/bean/Basket.hbm.xml" />
       </session-factory>
      
      </hibernate-configuration>
      


      My treecache.xml is : -

      <?xml version="1.0" encoding="UTF-8"?>
      
      <!-- ===================================================================== -->
      <!-- -->
      <!-- Sample TreeCache Service Configuration -->
      <!-- -->
      <!-- ===================================================================== -->
      
      <server>
      
       <classpath codebase="./lib" archives="jboss-cache.jar, jgroups.jar"/>
      
      
       <!-- ==================================================================== -->
       <!-- Defines TreeCache configuration -->
       <!-- ==================================================================== -->
      
       <mbean code="org.jboss.cache.TreeCache"
       name="jboss.cache:service=TreeCache">
      
       <depends>jboss:service=Naming</depends>
       <depends>jboss:service=TransactionManager</depends>
      
       <!--
       Configure the TransactionManager
       -->
       <attribute name="TransactionManagerLookupClass">org.jboss.cache.JBossTransactionManagerLookup</attribute>
      
      
       <!--
       Node locking level : SERIALIZABLE
       REPEATABLE_READ (default)
       READ_COMMITTED
       READ_UNCOMMITTED
       NONE
       -->
       <attribute name="IsolationLevel">SERIALIZABLE</attribute>
      
       <!--
       Valid modes are LOCAL
       REPL_ASYNC
       REPL_SYNC
       -->
       <attribute name="CacheMode">LOCAL</attribute>
      
      
       <!--
       Just used for async repl: use a replication queue
       -->
       <attribute name="UseReplQueue">false</attribute>
      
       <!--
       Replication interval for replication queue (in ms)
       -->
       <attribute name="ReplQueueInterval">20000</attribute>
      
       <!--
       Max number of elements which trigger replication
       -->
       <attribute name="ReplQueueMaxElements">5</attribute>
      
      
       <!-- Name of cluster. Needs to be the same for all clusters, in order
       to find each other
       -->
       <attribute name="ClusterName">TreeCache-Cluster</attribute>
      
       <!-- JGroups protocol stack properties. Can also be a URL,
       e.g. file:/home/bela/default.xml
       <attribute name="ClusterProperties"></attribute>
       -->
      
       <attribute name="ClusterConfig">
       <config>
       <!-- UDP: if you have a multihomed machine,
       set the bind_addr attribute to the appropriate NIC IP address -->
       <!-- UDP: On Windows machines, because of the media sense feature
       being broken with multicast (even after disabling media sense)
       set the loopback attribute to true -->
       <UDP mcast_addr="228.1.2.3" mcast_port="45566"
       ip_ttl="32" ip_mcast="true"
       mcast_send_buf_size="80000" mcast_recv_buf_size="150000"
       ucast_send_buf_size="80000" ucast_recv_buf_size="150000"
       loopback="true"/>
       <PING timeout="2000" num_initial_members="3"
       up_thread="false" down_thread="false"/>
       <MERGE2 min_interval="10000" max_interval="20000"/>
       <FD shun="true" up_thread="true" down_thread="true"/>
       <VERIFY_SUSPECT timeout="1500"
       up_thread="false" down_thread="false"/>
       <pbcast.NAKACK gc_lag="50" retransmit_timeout="600,1200,2400,4800"
       max_xmit_size="8192" up_thread="false" down_thread="false"/>
       <UNICAST timeout="600,1200,2400" window_size="100" min_threshold="10"
       down_thread="false"/>
       <pbcast.STABLE desired_avg_gossip="20000"
       up_thread="false" down_thread="false"/>
       <FRAG frag_size="8192"
       down_thread="false" up_thread="false"/>
       <pbcast.GMS join_timeout="5000" join_retry_timeout="2000"
       shun="true" print_local_addr="true"/>
       <pbcast.STATE_TRANSFER up_thread="false" down_thread="false"/>
       </config>
       </attribute>
      
      
       <!--
       The max amount of time (in milliseconds) we wait until the
       initial state (ie. the contents of the cache) are retrieved from
       existing members in a clustered environment
       -->
       <attribute name="InitialStateRetrievalTimeout">5000</attribute>
      
       <!--
       Number of milliseconds to wait until all responses for a
       synchronous call have been received.
       -->
       <attribute name="SyncReplTimeout">10000</attribute>
      
       <!-- Max number of milliseconds to wait for a lock acquisition -->
       <attribute name="LockAcquisitionTimeout">15000</attribute>
      
       <!-- Name of the eviction policy class. Not supported now. -->
       <attribute name="EvictionPolicyClass"></attribute>
      
      
       <attribute name="FetchStateOnStartup">true</attribute>
      
       </mbean>
      
      </server>
      
      


      Can anyboody explain why I am experiencing this kind of the problem.

      Thanks in Advance for any suggestion.

      Thanks
      Manjith.