0 Replies Latest reply on May 8, 2015 1:48 AM by Jessica Viles

    Wildfly 8.1.0 final, web app with JSF 1.2 internally packaged

    Jessica Viles Newbie

      I am attempting to deploy 2 wars via .cli script on Wildfly 8.1.0 final server, each application has internally packaged JSF, version 1.2.

       

      Applications deploy successfully, and drop event logs on start up.  The issue is none of the 2 web applications' views are accessible, they load as blank white pages and this log statement is logged in the server.log on deploy\undeploy:

       

      (2015-05-08T04:54:33.0189) SEVERE [javax.faces.FactoryFinder$FactoryManager.copyInjectionProviderFromFacesContext(FactoryFinder.java:1058)] (MSC service thread 1-1) Unable to obtain InjectionProvider from init time FacesContext. Does this container implement the Mojarra Injection SPI?

       

      I have tried to exclude all jsf related modules present, including the jsf and weld subsystems:

       

      <exclude-subsystems>
      <subsystem name="weld" />
      <subsystem name="jsf" />
      </exclude-subsystems>

       

      Still has same result.

       

      I found this bug that resolved for JSF 2.2.6, which is shows the same SEVERE level log statement:

       

      [WFLY-2594] Undeploy of JSF application is throwing SEVERE messages, when there were deployed more JSF apps - JBoss Issu…

       

      Any suggestions would be appreciated.