2 Replies Latest reply on May 13, 2015 4:44 AM by john mccosker

    Problem with jboss 6 native logging in Domain / Host cluster

    john mccosker Newbie

      Hi in my local host standalone.xml I have the following,

       

      <size-rotating-file-handler name="perfMetricsAppender" autoflush="true">

                      <formatter>

                          <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) correlationID[%X{correlationID}] userID[%X{userID}] threadID[%X{threadID}] serviceCall[%X{serviceCall}] %s%E%n"/>

                      </formatter>

                      <file relative-to="jboss.server.log.dir" path="performance.log"/>

                      <rotate-size value="100000m"/>

                      <max-backup-index value="30"/>

                      <append value="true"/>

                  </size-rotating-file-handler>

       

      <logger category="PERF_METRICS_LOGGER" use-parent-handlers="false">

                      <level name="INFO"/>

                      <handlers>

                          <handler name="perfMetricsAppender"/>

                      </handlers>

                  </logger>

       

      Which works as expected, jboss creates the looging.properties with the correct structure and logging behaves as expected.

       

      When we take this to the Domain JBOSS box and update the domain.xml with the above to the correct profile, the Host server has the correct logging.properties created on startup, the log file performance.log gets created also, but nothing gets appended to the log file, its empty.

       

      Is there something I have missed here in the cluster setup for logging.