1 Reply Latest reply on May 27, 2015 2:00 AM by Jozef Hartinger

    WildFly 10 and Weld 3

    Juergen Zimmermann Master

      I just took Weld's patchfile for WildFly 9, edited patch.xml (inside the zip file) for WildFly 10, and upgraded WildFly 10.0.0.Alpha1 to Weld 3.0.0.Alpha9. All my tests are working fine.

       

      Therefore, I'm wondering why WildFly 10 still includes Weld 2, and not Weld 3.

        • 1. Re: WildFly 10 and Weld 3
          Jozef Hartinger Master

          WildFly aims for compliance with Java EE 7 and CDI 1.2 On the other hand, Weld 3 Alpha stream are prototypes for CDI 2.0 with often changing API and behavior (as the spec is being written). Therefore, Weld 3 does not match the stability standard for WildFly at this point. We instead distribute the patches individually for experienced users who want to test-drive the new behavior but are aware of the risk of using it in production.