14 Replies Latest reply on Oct 11, 2009 11:24 PM by Peter Johnson

    How to set http port in 5.1.0GA

    tony anecito Novice

      Hi,
      How does one set the http port the correct way in 5.1.0GA? I googled and saw several different answers but saw that sometimes they worked and sometimes not. I am using the default deployment.

      Thanks,
      -Tony

        • 2. Re: How to set http port in 5.1.0GA
          Vicky Kak Master

           

          "tdanecito" wrote:
          Hi,
          How does one set the http port the correct way in 5.1.0GA?

          Do you mean the http connector port?
          You need to explain it in detail.


          • 3. Re: How to set http port in 5.1.0GA
            Vicky Kak Master

            However you can set the http connector port setting in server.xml at here
            $JBOSS_HOME/server//deploy/jbossweb.sar/server.xml

            • 4. Re: How to set http port in 5.1.0GA
              tony anecito Novice

              Hi All,

              Both solutions give a white page in the browser. When I revert back to port 8080 I get the html index page I expect. I put my html under default/deploy/ROOT.war

              Any ideas why I get a white or blank page for either solution?

              Thanks,
              -Tony

              • 5. Re: How to set http port in 5.1.0GA
                Vicky Kak Master

                 

                "tdanecito" wrote:

                Any ideas why I get a white or blank page for either solution?

                You are doing something wrong, all you have to do is
                1) make the port changes in server.xml for connector tag.
                2) start the Jboss
                3) Finally hit http://localhost:8081 , assuming that you have changed 8080 to 8081 in server.xml

                • 6. Re: How to set http port in 5.1.0GA
                  tony anecito Novice

                  Port 8080 and port 8081 work just fine.

                  I did turn off apache via its start/stop taskbar control. Could it be apache is still running something and I need to turn of the service some other way? I am running apache under windows prof 2000.

                  I there some log I should look at that might tell me what is wrong using http for port 80 for jboss 5.1.0?

                  Thanks,
                  -Tony

                  • 7. Re: How to set http port in 5.1.0GA
                    tony anecito Novice

                    Interesting port 81 & 82 work fine if I use either. If I set server.xml to port 80 I get a blank white page. In the logs there is no mention of a conflict. I even killed the apache monitor process.

                    -Tony

                    • 8. Re: How to set http port in 5.1.0GA
                      Vicky Kak Master

                      You can't get 80 running with non-root user starting JBoss process, it is a privileged port.
                      Start the Jboss with root user if you have configured server.xml connector for privileged ports(ports <1024 in linux)
                      http://www.klawitter.de/tomcat80.html
                      You may need to search the details over net to get things working, there is no issues from the Jboss front.

                      • 9. Re: How to set http port in 5.1.0GA
                        tony anecito Novice

                        I am logged into windows as the admin. Apache worked on port 80. It was recommend by the Apache group to use port 80 on JBoss for http.

                        -Tony

                        • 10. Re: How to set http port in 5.1.0GA
                          Peter Johnson Master

                           

                          However you can set the http connector port setting in server.xml at here
                          $JBOSS_HOME/server//deploy/jbossweb.sar/server.xml

                          Be aware that setting the HTTP port in server.xml will break the binding manager and thus prevent you from using the -Djboss.service.binding.set=xxx option to choose a set of port bindings. (Well, you can still use that option, but the HTTP port settings in bonding-jboss-beans.xml will be ignored, unless you also change the XSL transform at the end of the file.) If you plan to only ever run a single app server instance at a time, then it probably does not matter, but if you plan to run multiple instances then I recommend not changing server.xml but rather editing the bonding-jboss-beans.xml file instead.

                          • 11. Re: How to set http port in 5.1.0GA
                            Peter Johnson Master

                             

                            It was recommend by the Apache group to use port 80 on JBoss for http.

                            Actually, 80 is the default HTTP port (it's what is used if no port number is given in the URL). (Google 'http ports list' to see a list of standard ports.) You do not have to use port 80, it just depends on if you want to require your users to enter a port number as part of the URL or not (that is, http://somehost:8080/ vs. http://somehost/).

                            As long as no other process (such as IIS) is using port 80 you should be able to get JBoss AS to use it on windows. I don't think you need to run it as administrator, though the user running it might need admin privileges (it's been a while since I tried this so the details are a little fuzzy).

                            • 12. Re: How to set http port in 5.1.0GA
                              tony anecito Novice

                              Hi PeterJ,

                              Thanks for trying. I discovered if I downloaded the latest Tomcat setting it to port 80 works fine. If I take and install a clean copy of JBoss 5.1.0GA and set it to port 80 I get the white page with no html on the browser.

                              So my conclusion is for some reason on windows 2000 prof JBoss does not work with port 80 and it has to be JBoss specific since Tomcat 6.0.20 works fine.

                              Does JBoss come with APR for Tomcat installed? The regular tomcat does not have it that might be one difference.

                              Regards,
                              -Tony

                              • 13. Re: How to set http port in 5.1.0GA
                                tony anecito Novice

                                Hi PeterJ,

                                After spending a few more hours I found some more interesting info regarding using port 80 on JBoss,

                                1. IE will communicate properly and get the page correctly when I run IE on the PC where I have JBoss. FireFox will not display the page
                                2. My router will try to connect according to WireShark sniffer but the user gets a page not found.
                                3. IE and FireFox work fine communicating with port 8080.
                                4. Fiddler2 works fine with port 80 for JBoss.
                                5. I validated my index page with WC3 html validator and it is perfect for the html 4.01

                                FireFox plugin httpfox gets request response of ok 200 http 0.9 but Fiddler2 sees http 1.1 when running on the PC that has JBoss. I am FireFox 3.0.14

                                Got to be the oddest issue I have seen.

                                Regards,
                                -Tony

                                • 14. Re: How to set http port in 5.1.0GA
                                  Peter Johnson Master

                                   

                                  Does JBoss come with APR for Tomcat installed?

                                  No, not out of the box. You would have to install JBoss Native to get APR support.

                                  windows 2000 prof

                                  Any chance you could upgrade? That is a really old version of Windows and who knows what incompatibilities you will run into. Besides, with 2000 Pro I hope you do not have more than 10 incoming connections or you are violating the licensing.

                                  You litany of issues does sound bizarre. But as I mentioned, with such an old version of Windows, who knows that incompatibilities you are encountering.