5 Replies Latest reply on Jun 18, 2015 4:36 AM by Christoph Küster

    JBoss EAP 6.3.2.GA – EJB 3.1 – Resources - Problem

    Christoph Küster Newbie

      Hi,

       

      We use the JBoss EAP 6.3.2.GA Server with the following enfironment values:  JAVA_OPTS: -Xms2048m -Xmx2048m -XX:MaxPermSize=256m

       

      After some time, the response times are getting longer and later we get a memory error (heap space)

       

      We have change the  EJB 3.1 configuration in the standalone-full.xml <pools>   <remote connector-ref>  and thread-pools

       

      Is this EJB 3. 1 configration correct for EAP6.3.2 Server or the memory is too low?

      Does anyone havean idea or needs additional information?


       

      Here the full EJB- configuration:

      <subsystem xmlns="urn:jboss:domain:ejb3:1.4">

                  <session-bean>

                      <stateless>

                          <bean-instance-pool-ref pool-name="slsb-strict-max-pool"/>

                      </stateless>

                      <stateful default-access-timeout="5000" cache-ref="simple"/>

                      <singleton default-access-timeout="5000"/>

                  </session-bean>

                  <mdb>

                      <resource-adapter-ref resource-adapter-name="${ejb.resource-adapter-name:hornetq-ra}"/>

                      <bean-instance-pool-ref pool-name="mdb-strict-max-pool"/>

                  </mdb>

                 <pools>

                      <bean-instance-pools>

                          <strict-max-pool name="slsb-strict-max-pool" max-pool-size="1300" instance-acquisition-timeout="1" instance-acquisition-timeout-unit="MILLISECONDS"/>

                          <strict-max-pool name="mdb-strict-max-pool" max-pool-size="180" instance-acquisition-timeout="1" instance-acquisition-timeout-unit="MILLISECONDS"/>

                      </bean-instance-pools>

                  </pools>

                  <caches>

                      <cache name="simple" aliases="NoPassivationCache"/>

                      <cache name="passivating" passivation-store-ref="file" aliases="SimpleStatefulCache"/>

                  </caches>

                  <passivation-stores>

                      <file-passivation-store name="file"/>

                  </passivation-stores>

                  <async thread-pool-name="default"/>

                  <timer-service thread-pool-name="default">

                      <data-store path="timer-service-data" relative-to="jboss.server.data.dir"/>

                  </timer-service>

                  <remote connector-ref="remoting-connector" thread-pool-name="default">

                   <channel-creation-options>

                            <option name="WORKER_READ_THREADS" value="2" type="xnio"/>

                            <option name="WORKER_WRITE_THREADS" value="2" type="xnio"/>

                            <option name="MAX_INBOUND_MESSAGES" value="165" type="remoting"/>

                            <option name="MAX_OUTBOUND_MESSAGES" value="165" type="remoting"/>

                    </channel-creation-options>

                  </remote> 

                  <thread-pools>

                      <thread-pool name="default">

                          <max-threads count="165"/>

                          <keepalive-time time="75" unit="minutes"/>

                      </thread-pool>

                  </thread-pools>

                  <iiop enable-by-default="false" use-qualified-name="false"/>

                  <default-security-domain value="other"/>

      <default-missing-method-permissions-deny-access value="true"/>

              </subsystem>