0 Replies Latest reply on Jun 15, 2015 11:26 AM by tanaka.willian

    JBoss EAP 6.4.0.GA - Cluster - Session not replicating

    tanaka.willian Newbie

      Good morning and thanks in advance for any help or directions to narrow my problem!

       

      The problem is: I have just created a cluster with 3 physical servers, their IPs are:

       

      10.19.4.191 (master) - Master and 1 slave server

      10.19.4.192 (JBN1H) - Two slave servers

      10.19.4.193 (JBN2H) - Two slave servers


      I have divided the servers so I have two groups with 1 server each, and a cluster group with 3 servers.

      And the cluster form, as could be seen in the web-console


      domainOverview.png

      And in the mod_cluster_manager

      modClusterManager.png

      The problem is: The sessions are not being replicated. The test i made was setting the currentTimeInMillis into the session, stop the server that served that request, and refresh the page, but the timestamp in the session is just not there.


      Here is some configurations that I think are important:


      Infinispan from full-ha profile:

                  <subsystem xmlns="urn:jboss:domain:infinispan:1.5">

                      <cache-container name="singleton" aliases="cluster ha-partition" default-cache="default">

                          <transport lock-timeout="60000"/>

                          <replicated-cache name="default" mode="SYNC" batching="true">

                              <locking isolation="REPEATABLE_READ"/>

                          </replicated-cache>

                      </cache-container>

                      <cache-container name="web" aliases="standard-session-cache" default-cache="dist" module="org.jboss.as.clustering.web.infinispan">

                          <transport lock-timeout="60000"/>

                          <replicated-cache name="repl" mode="ASYNC" batching="true">

                              <file-store/>

                          </replicated-cache>

                          <replicated-cache name="sso" mode="SYNC" batching="true"/>

                          <distributed-cache name="dist" owners="2" l1-lifespan="0" mode="ASYNC" batching="true">

                              <file-store/>

                          </distributed-cache>

                      </cache-container>

                      <cache-container name="ejb" aliases="sfsb sfsb-cache" default-cache="dist" module="org.jboss.as.clustering.ejb3.infinispan">

                          <transport lock-timeout="60000"/>

                          <replicated-cache name="repl" mode="ASYNC" batching="true">

                              <eviction strategy="LRU" max-entries="10000"/>

                              <file-store/>

                          </replicated-cache>

                          <replicated-cache name="remote-connector-client-mappings" mode="SYNC" batching="true"/>

                          <distributed-cache name="dist" owners="2" l1-lifespan="0" mode="ASYNC" batching="true">

                              <eviction strategy="LRU" max-entries="10000"/>

                              <file-store/>

                          </distributed-cache>

                      </cache-container>

                      <cache-container name="hibernate" default-cache="local-query" module="org.jboss.as.jpa.hibernate:4">

                          <transport lock-timeout="60000"/>

                          <local-cache name="local-query">

                              <transaction mode="NONE"/>

                              <eviction strategy="LRU" max-entries="10000"/>

                              <expiration max-idle="100000"/>

                          </local-cache>

                          <invalidation-cache name="entity" mode="SYNC">

                              <transaction mode="NON_XA"/>

                              <eviction strategy="LRU" max-entries="10000"/>

                              <expiration max-idle="100000"/>

                          </invalidation-cache>

                          <replicated-cache name="timestamps" mode="ASYNC">

                              <transaction mode="NONE"/>

                              <eviction strategy="NONE"/>

                          </replicated-cache>

                      </cache-container>

                  </subsystem>

       

      Full-ha-sockets (which I changed custom ports and IPs):

              <socket-binding-group name="full-ha-sockets" default-interface="public">

                  <socket-binding name="ajp" port="8009"/>

                  <socket-binding name="http" port="8080"/>

                  <socket-binding name="https" port="8443"/>

                  <socket-binding name="jacorb" interface="unsecure" port="3528"/>

                  <socket-binding name="jacorb-ssl" interface="unsecure" port="3529"/>

                  <socket-binding name="jgroups-mping" port="0" multicast-address="${jboss.default.multicast.address:230.0.0.4}" multicast-port="45700"/>

                  <socket-binding name="jgroups-tcp" port="7600"/>

                  <socket-binding name="jgroups-tcp-fd" port="57600"/>

                  <socket-binding name="jgroups-udp" port="55200" multicast-address="${jboss.default.multicast.address:230.0.0.4}" multicast-port="45688"/>

                  <socket-binding name="jgroups-udp-fd" port="54200"/>

                  <socket-binding name="messaging" port="5445"/>

                  <socket-binding name="messaging-group" port="0" multicast-address="${jboss.messaging.group.address:231.7.7.7}" multicast-port="${jboss.messaging.group.port:9876}"/>

                  <socket-binding name="messaging-throughput" port="5455"/>

                  <socket-binding name="modcluster" port="0" multicast-address="${modcluster.multicast.address:230.0.2.2}" multicast-port="23364"/>

                  <socket-binding name="remoting" port="4447"/>

                  <socket-binding name="txn-recovery-environment" port="4712"/>

                  <socket-binding name="txn-status-manager" port="4713"/>

                  <outbound-socket-binding name="mail-smtp">

                      <remote-destination host="localhost" port="25"/>

                  </outbound-socket-binding>

              </socket-binding-group>


      Server-Groups:

      <server-groups>

              <server-group name="main-server-group-H" profile="full-ha">

                  <jvm name="default">

                      <heap size="2048m" max-size="6144m"/>

                      <permgen size="1024m" max-size="2048m"/>

                  </jvm>

                  <socket-binding-group ref="full-ha-sockets"/>

                  <deployments>

                      <deployment name="sped-ear-2.0.0-SNAPSHOT.ear" runtime-name="sped-ear-2.0.0-SNAPSHOT.ear"/>

                      <deployment name="session-server-1.0.4-SNAPSHOT.war" runtime-name="session-server-1.0.4-SNAPSHOT.war"/>

                  </deployments>

                  <system-properties>

                      <property name="jboss.messaging.group.address" value="230.0.2.0"/>

                      <property name="modcluster.multicast.address" value="230.0.2.1"/>

                      <property name="jboss.default.multicast.address" value="230.0.2.2"/>

                      <property name="mycluster.modcluster.lbgroup" value="MSGH"/>

                  </system-properties>

              </server-group>

              <server-group name="server-JBN1-H" profile="full-ha" management-subsystem-endpoint="false">

                  <jvm name="default">

                      <heap size="2048m" max-size="6144m"/>

                      <permgen size="1024m" max-size="2048m"/>

                  </jvm>

                  <socket-binding-group ref="full-ha-sockets" port-offset="0"/>

                  <system-properties>

                      <property name="jboss.messaging.group.address" value="230.0.2.0"/>

                      <property name="modcluster.multicast.address" value="230.0.2.1"/>

                      <property name="jboss.default.multicast.address" value="230.0.2.3"/>

                      <property name="mycluster.modcluster.lbgroup" value="JBN1H"/>

                  </system-properties>

              </server-group>

              <server-group name="server-JBN2-H" profile="full-ha" management-subsystem-endpoint="false">

                  <jvm name="default">

                      <heap size="2048m" max-size="6144m"/>

                      <permgen size="1024m" max-size="2048m"/>

                  </jvm>

                  <socket-binding-group ref="full-ha-sockets" port-offset="0"/>

                  <system-properties>

                      <property name="jboss.messaging.group.address" value="230.0.2.0"/>

                      <property name="modcluster.multicast.address" value="230.0.2.1"/>

                      <property name="jboss.default.multicast.address" value="230.0.2.4"/>

                      <property name="mycluster.modcluster.lbgroup" value="JBN2H"/>

                  </system-properties>

              </server-group>

          </server-groups>


      Any ideas on what i have done wrong? I have already read a lot of tutorials and web documentations but I really cant see the problem...