0 Replies Latest reply on Oct 6, 2006 9:25 PM by Modou Sanyang

    Invalid Schema Name in JBOSS EJB2.0

    Modou Sanyang Newbie

      Hi All,
      I am trying to deploy some EJB2.0 beans that are currently running in Weblogic. I transformed the Weblogic specific DDs to their JBOSS equivalents.
      After several debugging rounds, I have now successfully deployed all the beans (bundled along with a WAR in an EAR) in JBOSS4.0.4GA. However, when I access the application, I get an "Inavlid Schema Name" SQL exception on the following load relationship query:


      SELECT USERNAME FROM foo.GROUP_OWNER WHERE (GROUPNAME=?)


      The foo schema does exist and is owned and accessible by the user that connects the Datasource. In jbosscmp-jdbc.xml, the relationship is define as below:


      <ejb-relation>
      <ejb-relation-name>group-owner</ejb-relation-name>
      <relation-table-mapping>
      <table-name>foo.GROUP_OWNER</table-name>
      </relation-table-mapping>
      <ejb-relationship-role>
      <ejb-relationship-role-name>users-own-groups</ejb-relationship-role-name>
      <key-fields>
      <key-field>
      <field-name>userName</field-name>
      <column-name>USERNAME</column-name>
      </key-field>
      </key-fields>
      </ejb-relationship-role>
      <ejb-relationship-role>
      <ejb-relationship-role-name>groups-belongTo-users</ejb-relationship-role-name>
      <key-fields>
      <key-field>
      <field-name>name</field-name>
      <column-name>GROUPNAME</column-name>
      </key-field>
      </key-fields>
      </ejb-relationship-role>
      </ejb-relation>



      Any ideas what may be causing this problem? I would appreciate any pointers.

      regards,
      Modou