2 Replies Latest reply on Jun 20, 2015 12:58 AM by Stefan Raabe

    Virtual-Host Settings in Domain Mode?

    Stefan Raabe Newbie

      Hello, i've got a smaller problem. I want to transfer my running undertow virtualhost into domain mode. If i understand it copy past seams to be enough. But everytime i want to deploy a simple war i got the following error. In standalone it runs well. The domain/host XML config ist like in the offical description. Thanks in advance.

       

      ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) JBAS014613: Operation ("add") failed - address: ([

          ("subsystem" => "undertow"),

          ("server" => "default-server"),

          ("host" => "subapp1-host"),

          ("location" => "subapp1")

      ]) - failure description: {"JBAS014771: Services with missing/unavailable dependencies" => ["jboss.undertow.server.default-server.subapp1-host.location.subapp1 is missing [jboss.undertow.handler.subapp1-content]"]}

      2015-06-19 20:04:16,966 INFO  [org.jboss.as.server] (Controller Boot Thread) JBAS018559: Deployed "subapp1Web.war" (runtime-name : "subapp1Web.war")

      2015-06-19 20:04:16,987 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report

      JBAS014775:    New missing/unsatisfied dependencies:

            service jboss.undertow.handler.subapp1-content (missing) dependents: [service jboss.undertow.server.default-server.tdnghtdefault-host.location.subapp1]