0 Replies Latest reply on Oct 15, 2006 5:47 PM by Arup Sarkar

    Failed to set HarUrl attribute

    Arup Sarkar Newbie

      Hi:

      I am using JBoss 4.0.4GA version. I am getting an error while deploying the application. I have a hibernate-service.xml in my archive with the following contents. I have tried to put in as much details as possible. I am still not sure where I am going wrong. I have the following folder configuration in

      C:\jboss-4.0.4.GA\server\default\deploy\jboss-hibernate.deployer


      1. antlr-2.7.5H3.jar
      2. asm.jar
      3. asm-attrs.jar
      4. cglib-2.1.jar
      5. hibernate3.jar
      6. hibernate-metadata.jar
      7. jboss-hibernate.jar
      8. odmg-3.0.jar

      /META-INF
      /******* jboss-service.xml *****/
      <?xml version="1.0" encoding="UTF-8"?>
      <!DOCTYPE server>
      
      <server>
      
       <!--
       Defines the HAR (Hibernate ARchive) deployer service. See the javadocs for
       org.jboss.hibernate.har.HARDeployer for more info.
       -->
       <mbean code="org.jboss.hibernate.har.HARDeployer" name="jboss.har:service=HARDeployer">
       <attribute name="ValidateDTDs">false</attribute>
       </mbean>
      
      </server>
      

      /**** hibernate-service.xml*****/
      <server>
       <mbean code="org.jboss.hibernate.jmx.Hibernate" name="jboss.har:service=Hibernate">
       <attribute name="DatasourceName">java:/JBossAtWorkDS</attribute>
       <attribute name="Dialect">org.hibernate.dialect.HSQLDialect</attribute>
       <attribute name="SessionFactoryName">java:/hibernate/SessionFactory</attribute>
       <attribute name="CacheProviderClass">org.hibernate.cache.HashtableCacheProvider</attribute>
       <attribute name="Hbm2ddlAuto">update</attribute>
       </mbean>
      </server>
      


      /**** jboss-app.xml ****/
      <!DOCTYPE jboss-app PUBLIC "-//JBoss//DTD J2EE Application 1.4//EN" "http://www.jboss.org/j2ee/dtd/jboss-app_4_0.dtd">
      <jboss-app>
       <module>
       <har>jaw.har</har>
       </module>
      </jboss-app>
      


      /**** CarDTO.hbm.xml ****/
      <?xml version="1.0" encoding="UTF-8"?>
      
      <!DOCTYPE hibernate-mapping PUBLIC
       "-//Hibernate/Hibernate Mapping DTD 3.0//EN"
       "http://hibernate.sourceforge.net/hibernate-mapping-3.0.dtd">
      
      <hibernate-mapping
      >
       <class
       name="com.jbossatwork.dto.CarDTO"
       table="CAR"
       >
      
       <id
       name="id"
       column="ID"
       type="int"
       >
       <generator class="native">
       <!--
       To add non XDoclet generator parameters, create a file named
       hibernate-generator-params-CarDTO.xml
       containing the additional parameters and place it in your merge dir.
       -->
       </generator>
       </id>
      
       <property
       name="make"
       type="java.lang.String"
       update="true"
       insert="true"
       column="MAKE"
       />
      
       <property
       name="model"
       type="java.lang.String"
       update="true"
       insert="true"
       column="MODEL"
       />
      
       <property
       name="modelYear"
       type="java.lang.String"
       update="true"
       insert="true"
       column="MODEL_YEAR"
       />
      
       <!--
       To add non XDoclet property mappings, create a file named
       hibernate-properties-CarDTO.xml
       containing the additional properties and place it in your merge dir.
       -->
      
       </class>
      
      </hibernate-mapping>
      


      /******** JBoss Deployment Error ***********/
      --- Incompletely deployed packages ---
      org.jboss.deployment.DeploymentInfo@4ddf9b11 { url=file:/C:/jboss-4.0.4.GA/server/default/deploy/jaw.ear }
       deployer: org.jboss.deployment.EARDeployer@4eeaaf
       status: Deployment FAILED reason: Failed to set HarUrl attribute: Attribute 'HarUrl' is not writable; - nested throwable: (javax.management.AttributeNotFoundException: Attribute 'HarUrl' is not writable)
       state: FAILED
       watch: file:/C:/jboss-4.0.4.GA/server/default/deploy/jaw.ear
       altDD: null
       lastDeployed: 1160945791796
       lastModified: 1160945791437
       mbeans:
      
      org.jboss.deployment.DeploymentInfo@3bc672c0 { url=file:/C:/jboss-4.0.4.GA/server/default/deploy/jaw-ds-with-comments.xml }
       deployer: null
       status: null
       state: INIT_WAITING_DEPLOYER
       watch: file:/C:/jboss-4.0.4.GA/server/default/deploy/jaw-ds-with-comments.xml
       altDD: null
       lastDeployed: 1160945792234
       lastModified: 1160945792218
       mbeans:
      
      --- MBeans waiting for other MBeans ---
      ObjectName: jboss.har:service=Hibernate
       State: CONFIGURED
       I Depend On:
       jboss.jca: name=JBossAtWorkDS,service=LocalTxCM
      
      --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
      ObjectName: jboss.jca: name=JBossAtWorkDS,service=LocalTxCM
       State: NOTYETINSTALLED
       Depends On Me:
       jboss.har:service=Hibernate
      
      [list=]