3 Replies Latest reply on Jun 30, 2015 6:02 PM by Diego Hidalgo

    WildFly 8.2: Why do all number-of-*-transactions stay 0, even though TX statistics is enabled?

    Rasmus Lund Newbie

      In standalone.xml I have enabled TX statistics (line 8 below):

      <subsystem xmlns="urn:jboss:domain:transactions:2.0">
          <core-environment>
              <process-id>
                  <uuid/>
              </process-id>
          </core-environment>
          <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>
          <coordinator-environment statistics-enabled="true"/>
      </subsystem>
      
      

       

      I use the following cmd in JBoss CLI GUI:

      /subsystem=transactions/:read-resource(recursive=true,include-runtime=true)
      
      

       

      Which gives the following result:

      {
          "outcome" => "success",
          "result" => {
              "default-timeout" => 300,
              "enable-statistics" => true,
              "enable-tsm-status" => false,
              "hornetq-store-enable-async-io" => false,
              "jdbc-action-store-drop-table" => false,
              "jdbc-action-store-table-prefix" => undefined,
              "jdbc-communication-store-drop-table" => false,
              "jdbc-communication-store-table-prefix" => undefined,
              "jdbc-state-store-drop-table" => false,
              "jdbc-state-store-table-prefix" => undefined,
              "jdbc-store-datasource" => undefined,
              "jts" => false,
              "node-identifier" => "1",
              "number-of-aborted-transactions" => 0L,
              "number-of-application-rollbacks" => 0L,
              "number-of-committed-transactions" => 0L,
              "number-of-heuristics" => 0L,
              "number-of-inflight-transactions" => 0L,
              "number-of-nested-transactions" => 0L,
              "number-of-resource-rollbacks" => 0L,
              "number-of-timed-out-transactions" => 0L,
              "number-of-transactions" => 0L,
              "object-store-path" => "tx-object-store",
              "object-store-relative-to" => "jboss.server.data.dir",
              "path" => "var",
              "process-id-socket-binding" => undefined,
              "process-id-socket-max-ports" => 10,
              "process-id-uuid" => true,
              "recovery-listener" => false,
              "relative-to" => "jboss.server.data.dir",
              "socket-binding" => "txn-recovery-environment",
              "statistics-enabled" => true,
              "status-socket-binding" => "txn-status-manager",
              "use-hornetq-store" => false,
              "use-jdbc-store" => false,
              "log-store" => {"log-store" => {
                  "type" => "default",
                  "transactions" => undefined
              }}
          }
      }
      
      

       

      Problem is that all the tx counters stay on 0, even though I run code that uses transactions.

       

      Note: Our DataSources are defined as XML files in the deployments folder (if that makes a difference).