4 Replies Latest reply on Jul 6, 2015 5:58 AM by Greg Jewell

    Quartz module installation not working

    tailorbird indian Newbie

      I was trying to deploy my application in WildFly 8.2.0 and getting the following errors. It is not able to find the quarts jar, where I have installed it as a module with the help of this documentation.

       

      error:

       

      Caused by: java.lang.NoClassDefFoundError: org/quartz/Trigger

              at java.lang.Class.getDeclaredFields0(Native Method) [rt.jar:1.7.0_80]

              at java.lang.Class.privateGetDeclaredFields(Class.java:2509) [rt.jar:1.7.0_80]

              at java.lang.Class.getDeclaredFields(Class.java:1819) [rt.jar:1.7.0_80]

              at org.jboss.as.server.deployment.reflect.ClassReflectionIndex.<init>(ClassReflectionIndex.java:57) [wildfly-server-8.2.0.Final.jar:8.2.0.Final]

              at org.jboss.as.server.deployment.reflect.DeploymentReflectionIndex.getClassIndex(DeploymentReflectionIndex.java:68) [wildfly-server-8.2.0.Final.jar:8.2.0.Final]

       

       

      I have the jar file and module.xml inside the

      /modules/org/quartz/main

       

      module.xml:

       

      <module xmlns="urn:jboss:module:1.1" name="org.quartz"> 

        <resources> 

          <resource-root path="quartz-2.0.2.jar"/> 

        </resources> 

        <dependencies> 

                <module name="org.slf4j"/> 

                <module name="javax.api"/> 

        </dependencies> 

      </module> 

       

       

      What else I have to do to take this dependency in action? Do we need to specify this quartz module info somewhere else?

       

      Tried putting Dependency: org.quartz in MANIFEST.MF and in jboss-deployment-structure.xml. But not worked.

       

      <jboss-deployment-structure>

          <deployment>

      <dependencies>

                  <module name="org.quartz" />

              </dependencies>      

          </deployment>

      </jboss-deployment-structure>