1 Reply Latest reply on Jul 15, 2015 8:11 PM by Terrence Curran

    Wildfly 9.0 Infinispan subsystem does not register JNDI. bug or feature?

    Terrence Curran Newbie

      In Wildfly 8.0, we have some Infinispan Cache containers we are using for hibernate search. It looks similar to this:

       

      <cache-container name="hibernateSearch" default-cache="LuceneIndexesData">
        <transport lock-timeout="330000"/>
        <replicated-cache name="LuceneIndexesMetadata" mode="SYNC" remote-timeout="330000">
        <locking striping="false" acquire-timeout="330000" concurrency-level="500"/>
        <transaction mode="NONE"/>
        <eviction strategy="NONE" max-entries="-1"/>
        <expiration max-idle="-1"/>
        <state-transfer enabled="true" timeout="480000"/>
        <indexing index="NONE"/>
        <file-store preload="true" purge="false" passivation="false" relative-to="jboss.home.dir"
        path="standalone/data/infinispan-file-store">
        <write-behind/>
        </file-store>
        </replicated-cache>
      </cache-container>
      

       

      Within Hibernate, Search then references this Cache container at the following JNDI address: "java:jboss/infinispan/container/hibernateSearch".

       

      With Wildfly 9.0, I am not seeing the cache container at that JNDI address, or any other address. Even if I specify one directly with jndi-name="java:/cache/hibernateSearch", it doesn't seem to register.

       

      Digging-into the code, I believe it may be caused by this commit:

      https://github.com/rhusar/wildfly/commit/01f7a81d82ad0738389c2895b60ff72834e4da9b

       

      Does anyone know what my issue is? Am I configuring it incorrectly? Do I need to do something to get Infinispan to register with the naming module?