6 Replies Latest reply on Aug 3, 2015 5:24 AM by Michal Petrov

    RF ResourceServlet not working after upgrading from RF 4.3.4 to RF 4.5.1

    Immo Benjes Newbie

      Hi

       

      I am trying to upgrade from RF 4.3.4 to RF 4.5.1.Final but suddenly the packed.js, packed.css and jquery.js files cannot be loaded anymore:

      >localhost:8080/MyAPP/org.richfaces.resources/javax.faces.resource/org.richfaces.staticResource/4.5.1.Final/PackedCompressed/DEFAULT/packed/packed.css

      >localhost:8080/MyAPP/org.richfaces.resources/javax.faces.resource/org.richfaces.staticResource/4.5.1.Final/PackedCompressed/packed/packed.js

      >localhost:8080/MyAPP/org.richfaces.resources/javax.faces.resource/org.richfaces.staticResource/4.5.1.Final/PackedCompressed/org.richfaces/jquery.js

       

      All come back with a 404 error.

       

      The page itself builds fine and I can see this in the logfile:

      >RichFaces Core by JBoss by Red Hat, version 4.5.1.Final

       

      With RF 4.3.4 we had 4 jars,

       

      richfaces-components-api-4.3.4.Final.jar

      richfaces-core-api-4.3.4.Final.jar

      deployed to the main application lib directory

       

      and

       

      richfaces-components-ui-4.3.4.Final.jar

      richfaces-core-impl-4.3.4.Final.jar

      which were deployed to the /WEB-INF/lib directory of the war.

       

      I now have all 3 deployed to the main lib directory (is that correct?)

       

       

      The setup is JBoss EAP 6.1.0.GA (AS 7.2.0.Final-redhat-8)

      Seam 2.3.1.Final

       

      We also deploy Primeface 5.2. The combination RF 4.3.4 and PF 4.0 or RF 4.3.4 and PF 5.2 works fine (we used to have a fix that both load the same jQuery version but I have taken that out, to see whether that was causing the problem but that wasn't the case).

       

      Any ideas what could be wrong here?

       

       

      This is an extract of our web.xml:

      
      <web-app version="3.0"
       xmlns="http://java.sun.com/xml/ns/javaee"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_3_0.xsd">
      
       
       <!--  RichFaces -->
      <context-param> <param-name>org.richfaces.queue.global.enabled</param-name> 
      <param-value>true</param-value>
      </context-param>
      
      
      
         <!-- Suppress spurious stylesheets -->
      
         <context-param>
            <param-name>org.richfaces.enableControlSkinning</param-name>
            <param-value>false</param-value>
         </context-param>
      
         <context-param>
            <param-name>org.richfaces.enableControlSkinningClasses</param-name>
            <param-value>false</param-value>
         </context-param>
      
         <!-- Change load strategy to DEFAULT to disable sending scripts/styles as packs -->
      
         <context-param>
            <param-name>org.richfaces.resourceOptimization.enabled</param-name>
            <param-value>true</param-value>
         </context-param>
      
      <!-- more custom non-RF related stuff -->
      </web-app>
      

       

      Thanks for your help