1 Reply Latest reply on Aug 7, 2015 4:14 PM by david crocker

    Missing artifacts in switchyard-example using 2.15.1.redhat-620133 JBoss Tools version

    david crocker Newbie

      I have been trying to follow the tutorial at Tutorial - SwitchYard - Project Documentation Editor but am stopped because of two Maven dependencies.

       

      I loaded the switchyard-example project but got errors.

       

      These are the errors:

      Missing artifact org.apache.camel:camel-core:jar:2.15.1.redhat-620133

      Missing artifact org.apache.camel:camel-cdi:jar:2.15.1.redhat-620133

       

       

      Can anyone suggest an approach for resolving this issue?

       

      Below find a history of what I have already tried:

       

      my jbds version is:

      Version: 7.1.1.GA

      Build id: GA-v20140314-2145-B688

      Build date: 20140314-2145

       

      I loaded my tooling from here:

      JBoss Tools - All Downloads

       

      With the following archives:

      jbdevstudio-integration-stack-updatesite-7.1.0.GA.zip

      jbdevstudio-product-eap-universal-7.1.1.GA-v20140314-2145-B688.jar

      jbdevstudio-product-Update-7.1.1.GA-v20140314-2145-B688.zip

      jbosstools-integration-stack-aggregate-4.1.7.Final.zip

      jbosstools-Update-4.1.2.Final_2014-03-18_15-46-19-B706.zip

       

      In the Effective POM I see the following:

      <dependency>

      <groupId>org.apache.camel</groupId>

      <artifactId>camel-cdi</artifactId>

      <version>2.15.1.redhat-620133</version>

      </dependency>

      <dependency>

      <groupId>org.apache.camel</groupId>

      <artifactId>camel-core</artifactId>

      <version>2.15.1.redhat-620133</version>

      </dependency>


      I downloaded similar jars and placed them in my repository:

      Maven Repository: org.apache.camel » camel-core » 2.15.2

      mvn install:install-file  -Dfile=C:\Downloads\Development\camel-core-2.15.1.jar -DgroupId=org.apache.camel -DartifactId=camel-core -Dversion=2.15.1 -Dpackaging=jar


        • 1. Re: Missing artifacts in switchyard-example using 2.15.1.redhat-620133 JBoss Tools version
          david crocker Newbie

          SOLVED

          I ended up removing the entire JBDS installation and starting over again.

           

          There are two critical pieces to add to the JBoss Tools Maven section.  This piece requires clarification.  You do NOT configure this through the Eclipse MAVEN GUI.  Instead, you configure it through the following:

          Window -> Preferences -> JBoss Tools -> JBoss Maven Integration -> Configure Maven Repositories

           

          jboss-earlyaccess-repository

          http://maven.repository.redhat.com/earlyaccess/all/

           

          and

           

          jboss-enterprise-repository-group

          http://maven/repostory.redhat.com/techpreview/all/

           

          I also had other stuff in there, but I'm not sure that it matters.  A lot of stuff that I describe here might be unnecessary, but I'm a noob, so I just don't know.  It would be great to understand how things work under the covers.  Maybe someone more knowledgeable than I can comment.

           

          I checked the Early Access box on JBoss Central -> Software/Update.

           

          I added the tooling by going to

           

          Help -> Install New Software

          https://devstudio.redhat.com/updates/8.0/integration-stack/earlyaccess/

          https://devstudio.redhat.com/updates/8.0/

          https://devstudio.redhat.com/earlyaccess/8.0

          https://download.jboss.org/jbosstools/updates/development/luna/integration-stack/earlyaccess

          https://devstudio.redhat.com/updates/8.0/integration-stack

           

          Some of these are probably unnecessary.

           

          I still couldn't get the switch-yard example to work.  So I ended up making a backup of the {user.home}/.m2/settings.xml file and replacing it with one from a working installation.  Then I ran the following:

           

          New -> Other -> SwitchYard -> SwitchYard Project

           

          And the configuration jars got reloaded.

           

           

          Here's the GOOD settings.xml file:

           

          <?xml version="1.0" encoding="UTF-8" standalone="no"?>

          <settings>

              <profiles>

                  <profile>

                      <id>jboss-public-repository-group</id>

                      <activation>

                          <activeByDefault>true</activeByDefault>

                      </activation>

                      <repositories>

                          <repository>

                              <id>jboss-public-repository-group</id>

                              <name>JBoss Public Repository Group</name>

                              <url>http://repository.jboss.org/nexus/content/groups/public/</url>

                              <layout>default</layout>

                              <releases>

                                  <enabled>true</enabled>

                                  <updatePolicy>never</updatePolicy>

                              </releases>

                              <snapshots>

                                  <enabled>true</enabled>

                                  <updatePolicy>never</updatePolicy>

                              </snapshots>

                          </repository>

                          <repository>

                              <id>jboss-enterprise-repository-group</id>

                              <name>JBoss Enterprise Maven Repository Group</name>

                              <url>http://maven.repository.redhat.com/techpreview/all/</url>

                              <layout>default</layout>

                              <releases>

                                  <enabled>true</enabled>

                                  <updatePolicy>never</updatePolicy>

                              </releases>

                              <snapshots>

                                  <enabled>true</enabled>

                                  <updatePolicy>never</updatePolicy>

                              </snapshots>

                          </repository>

                          <repository>

                              <id>fusesource-public-release-repository-group</id>

                              <url>https://repository.jboss.org/nexus/content/repositories/fs-releases</url>

                              <releases>

                                  <enabled>true</enabled>

                                  <updatePolicy>never</updatePolicy>

                              </releases>

                              <snapshots>

                                  <enabled>true</enabled>

                                  <updatePolicy>never</updatePolicy>

                              </snapshots>

                          </repository>

                      </repositories>

                      <pluginRepositories>

                          <pluginRepository>

                              <id>jboss-public-repository-group</id>

                              <name>JBoss Public Maven Repository Group</name>

                              <url>https://repository.jboss.org/nexus/content/groups/public/</url>

                              <layout>default</layout>

                              <releases>

                                  <enabled>true</enabled>

                                  <updatePolicy>never</updatePolicy>

                              </releases>

                              <snapshots>

                                  <enabled>true</enabled>

                                  <updatePolicy>never</updatePolicy>

                              </snapshots>

                          </pluginRepository>

                      </pluginRepositories>

                  </profile>

              <profile>

                <id>jboss-earlyaccess-repository</id>

                <repositories>

                  <repository>

                    <id>jboss-earlyaccess-repository</id>

                    <name>jboss-earlyaccess-repository</name>

                    <url>http://maven.repository.redhat.com/earlyaccess/all/</url>

                  </repository>

                </repositories>

                <pluginRepositories>

                  <pluginRepository>

                    <id>jboss-earlyaccess-repository</id>

                    <name>jboss-earlyaccess-repository</name>

                    <url>http://maven.repository.redhat.com/earlyaccess/all/</url>

                  </pluginRepository>

                </pluginRepositories>

              </profile>

            </profiles>

          <activeProfiles>

              <activeProfile>jboss-earlyaccess-repository</activeProfile>

            </activeProfiles>

          </settings>

           

          The bad settings.xml file had all of the same stuff but in a different order.