2 Replies Latest reply on Aug 4, 2015 7:55 AM by Steve Hold

    Apache Advertising with JBoss EAP 6.3 Issues

    Steve Hold Newbie

      Hello,

       

      I'm trying to get Apache and JBoss EAP 6.3 standalone advertising and discovery working with mod_cluster 1.3.1.  It looks like Apache is advertising and Jboss is receiving, but it doesn't appear to be accepting responses from JBoss.  Here is the error I am getting:

       

      08:20:28,069 ERROR [org.jboss.modcluster] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) MODCLUSTER000043: Failed to send INFO to localhost/127.0.0.1:6666: java.net.ConnectException: Connection refused

          at java.net.PlainSocketImpl.socketConnect(Native Method) [rt.jar:1.7.0_67]

          at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339) [rt.jar:1.7.0_67]

          at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200) [rt.jar:1.7.0_67]

          at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182) [rt.jar:1.7.0_67]

          at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) [rt.jar:1.7.0_67]

          at java.net.Socket.connect(Socket.java:579) [rt.jar:1.7.0_67]

          at org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler$Proxy.getConnection(DefaultMCMPHandler.java:835)

          at org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler$Proxy.getConnectionWriter(DefaultMCMPHandler.java:858)

          at org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler.sendRequest(DefaultMCMPHandler.java:499)

          at org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler.sendRequest(DefaultMCMPHandler.java:600)

          at org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler.status(DefaultMCMPHandler.java:372)

          at org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler.status(DefaultMCMPHandler.java:350)

          at org.jboss.modcluster.ModClusterService.status(ModClusterService.java:458)

          at org.jboss.modcluster.container.catalina.CatalinaEventHandlerAdapter.lifecycleEvent(CatalinaEventHandlerAdapter.java:249)

          at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:115) [jbossweb-7.4.8.Final-redhat-4.jar:7.4.8.Final-redhat-4]

          at org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBase.java:1323) [jbossweb-7.4.8.Final-redhat-4.jar:7.4.8.Final-redhat-4]

          at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1588) [jbossweb-7.4.8.Final-redhat-4.jar:7.4.8.Final-redhat-4]

          at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.run(ContainerBase.java:1574) [jbossweb-7.4.8.Final-redhat-4.jar:7.4.8.Final-redhat-4]

          at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_67]

       

      08:20:28,086 ERROR [org.jboss.modcluster] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) MODCLUSTER000042: Error null sending INFO command to 172.xx.xx.xx/172.xx.xx.xx:6666, configuration will be reset: null

      08:20:38,090 ERROR [org.jboss.modcluster] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) MODCLUSTER000042: Error null sending INFO command to 172.xx.xx.xx/172.xx.xx.xx:6666, configuration will be reset: null

      08:20:48,095 ERROR [org.jboss.modcluster] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) MODCLUSTER000042: Error null sending INFO command to 172.xx.xx.xx/172.xx.xx.xx:6666, configuration will be reset: null

      08:20:58,099 ERROR [org.jboss.modcluster] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) MODCLUSTER000042: Error null sending INFO command to 172.xx.xx.xx/172.xx.xx.xx:6666, configuration will be reset: null....

       

       

      Here is my mod_cluster.conf file on my Apache server:

       

      CreateBalancers 1

       

      <IfModule manager_module>

          Listen 172.xx.xx.xx:6666

          ManagerBalancerName mycluster

       

          <VirtualHost 172.xx.xx.xx:6666>

              KeepAliveTimeout 300

              MaxKeepAliveRequests 0

              AdvertiseFrequency 5

              AdvertiseGroup 224.0.1.105:23364

              EnableMCPMReceive

              <Location />

                  Order deny,allow

                  Allow from all

                  #Allow from 172.xx.xx.xx

              </Location>

       

           </VirtualHost>

       

      </IfModule>

       

      I also ran these commands at the jboss command line:

       

      batch
      /subsystem=modcluster:add

      /subsystem=modcluster/mod-cluster-config=configuration:add(connector=ajp,advertise-socket=modcluster)

      run-batch

       

       

      Any suggestions are helpful.  Thank you in advance.

        • 1. Re: Apache Advertising with JBoss EAP 6.3 Issues
          Steve Hold Newbie

          Here's an update.

           

          I've taken down my firewall down on both machines and it is still not connecting.  I am running this on an Ubuntu system.

           

          Here is the Apache output when it fails to connect:

          [Tue Aug 04 07:27:01.311348 2015] [authz_core:error] [pid 47538:tid 140033625409280] [client 172.17.2.49:49526] AH01630: client denied by server configuration: /

           

          On the JBoss side it's still returning:

           

          08:20:28,086 ERROR [org.jboss.modcluster] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) MODCLUSTER000042: Error null sending INFO command to 172.xx.xx.xx/172.xx.xx.xx:6666, configuration will be reset: null

           

          Here is my JBoss modcluster config:

           

           

          <subsystem xmlns="urn:jboss:domain:modcluster:1.2">

                          <mod-cluster-config advertise="false" connector="ajp" proxy-list="172.xx.xx.xx:6666">

                          <dynamic-load-provider>

                              <load-metric type="busyness"/>

                          </dynamic-load-provider>

                      </mod-cluster-config>

                  </subsystem>

           

          Here is my updated Apache mod_cluster.conf file:

           

           

          CreateBalancers 1

           

          <IfModule manager_module>

              Listen 172.xx.xx.xx:6666

              #ManagerBalancerName mycluster

           

              <VirtualHost 172.xx.xx.xx:6666>

                  ServerName jboss1.clus.domain

                  EnableMCPMReceive On

                  <Directory />

                          Order deny,allow

                          #Deny from all

                          Allow from 172.xx.xx.0/24

                          Allow from 127.0.0.1

                  </Directory>

           

               </VirtualHost>

           

          </IfModule>

           

          Again, any suggestions are helpful.  I haven ot been able to resolve this with any advice from forums or net searches. I've been struggling with getting this issue for some time now.  Thank you.

          • 2. Re: Apache Advertising with JBoss EAP 6.3 Issues
            Steve Hold Newbie

            I was able to resolve my problem it had to do with updated Apache 2.4 rules:

             

            2.2 configuration:

            Order allow,deny Allow from all 

            2.4 configuration:

            Require all granted