2 Replies Latest reply on Aug 4, 2015 7:17 PM by Tomaz Cerar

    Building with the IBM J9 java compiler

    Michael Musgrove Master

      I am getting an error from the maven enforcer plugin when building with the IBM J9 java compiler:

       

      [INFO] --- maven-enforcer-plugin:1.4:enforce (ban-transitive-deps) @ wildfly-feature-pack ---

      [WARNING] Rule 0: org.apache.maven.plugins.enforcer.BanTransitiveDependencies failed with message:

      org.wildfly:wildfly-feature-pack:pom:10.0.0.Beta1-SNAPSHOT

         org.apache.cxf:cxf-rt-security-saml:jar:3.1.2:compile has transitive dependencies:

            xalan:xalan:jar:2.7.1.jbossorg-1:compile

               xalan:serializer:jar:2.7.1.jbossorg-1:compile

       

      and the compiler details are:

       

      java version "1.8.0"

      Java(TM) SE Runtime Environment (build pxa6480sr1-20150417_01(SR1))

      IBM J9 VM (build 2.8, JRE 1.8.0 Linux amd64-64 Compressed References 20150410_243669 (JIT enabled, AOT enabled)

      J9VM - R28_Java8_SR1_20150410_1531_B243669

      JIT  - tr.r14.java_20150402_88976.03

      GC   - R28_Java8_SR1_20150410_1531_B243669_CMPRSS

      J9CL - 20150410_243669)

      JCL - 20150413_01 based on Oracle jdk8u45-b13

       

      Has anyone else seen and overcome this problem - I have had it building with this compiler version in the past.