2 Replies Latest reply on Aug 19, 2015 4:56 AM by Harish V

    context root is not coming in url if we deploy application in root (/) EAP 6.3.0

    Harish V Newbie

      Hi Experts,

       

      we are using JBOSS EAP 6.3.0/JBOSS AS 7.1.0

       

      Enabled SSL as below in standalone.xml

       

      <connector name="https" protocol="HTTP/1.1" scheme="https" socket-binding="https">

              <ssl name="ssl" key-alias="application" password="123application" certificate-key-file="${jboss.server.config.dir}/KeyServer.jks" protocol="TLSv1" verify-client="false"/>

      </connector>

       

      But when i access the application by using https://localhost/application it is getting hanged and unable to perform any operation

       

      later i have changed the below things for default application

       

      disabling enable-welcome-root="false" in standalone.xml and creating a jboss-web.xml inside the application war as below

      <jboss-web>

      <context-root>/</context-root>

      </jboss-web>

       

      After deploying the application am unable to access it by using https://localhost/application it is throwing 500- Internal Server Error

      Able to access  by using https://localhost/  with out any issues. But context root is not getting displayed in the url and the url has been already published in so many places and being used by a large base of users.

      Is there any way to display the context root in the URL even after doing the above 2 settings.

       

      Regards,

      Harish