2 Replies Latest reply on Aug 28, 2015 1:10 PM by Rangel Zutin

    Migration from WildFly 8.2 to JBoss EAP 6.4

    Rangel Zutin Newbie

      Please,

       

      I'm doing some tests to migrate a Java EE application from a WildFly 8.2 environment to a JBoss EAP 6.4 one.

      The application uses some security features from Undertow server to handle user sessions and SSL certificates and those are natives from WildFly 8.2, but NOT native on JBoss EAP 6.4 that is based on Apache web server.

      Is that a great issue? Will I have to change the source codes?

      Will I have to embed Undertow in JBoss EAP? Is that the way?

      Honestly I’m bit lost in this issue.

       

      Thanks so much in advance!

       

      Rangel.

        • 1. Re: Migration from WildFly 8.2 to JBoss EAP 6.4
          Tomaz Cerar Master
          The application uses some security features from Undertow server to handle user sessions and SSL certificates and those are natives from WildFly 8.2, but NOT native on JBoss EAP 6.4 that is based on Apache web server

           

          What exactly do you mean by that?

           

          EAP uses apache web server as front end server and proxy, and also has option to use APR as protocol which uses some native stuff from apache web server.

          but you don't have to use that.

           

          So what exactly you don't know how to map/migrate?

          • 2. Re: Migration from WildFly 8.2 to JBoss EAP 6.4
            Rangel Zutin Newbie

            Thanks so much for your reply!

            I just had a quick contact with the JavaEE application that is developed and owned by a third part team using WildFly 8.2 today. I know all SSL authentication security process was developed based on Undertow and now they want to migrate that to JBoss EAP 6.4.

            This team already tried migrate this application just building and deploying a version for this server, but they faced many issues related to the Undertow component once that is not part of JBoss EAP 6.4 pack.

            So I am lost about is the best way to assist them in this compatibility.