3 Replies Latest reply on Sep 3, 2015 9:28 AM by Justin Bertram

    <security-enabled>true</security-enabled> in messaging subsystem not working in JBOSS Wildfly.

    Vinoth Kumar J Newbie

      I'm trying to add authentication for the JMS messaging in wildfly. But when I enable the <security-enabled> to true it throws an error stating the concerned user has no permissions to consume/send. The below is my standalone_full.xml sections:

       

      <subsystem xmlns="urn:jboss:domain:messaging:2.0">

                  <hornetq-server>

                      <security-enabled>false</security-enabled>

           ...............................


                       <security-settings>

                          <security-setting match="#">

                              <permission type="send" roles="guest"/>

                              <permission type="consume" roles="guest"/>

                              <permission type="createNonDurableQueue" roles="guest"/>

                              <permission type="deleteNonDurableQueue" roles="guest"/>

                          </security-setting>

                      </security-settings>

                   

      In the application-users.properties I have added a user admin, admin=2a0923285184943425d1f53ddd58ec7a and in the application-roles.properties I have given admin the role as guest.

       

       

      Do I have to configure the security settings somewhere else?

       

      Please help me in adding those.