1 Reply Latest reply on Sep 18, 2015 11:06 PM by Alex Padilla

    installing JBPM 6.2.0 final on MAC OS Yosemite version 10.10.5

    Alex Padilla Newbie

      Hii everyone, I tried to install the jBPM  6.2.0 final but when i execute the command >   ant install.demo it gave me the following error:

      install.modeler.into.eclipse:

           [exec] 2015-09-13 23:35:42.544 eclipse[1727:184043] Error loading /Library/Java/JavaVirtualMachines/jdk1.8.0_60.jdk/Contents/MacOS/libjli.dylib:  dlopen(/Library/Java/JavaVirtualMachines/jdk1.8.0_60.jdk/Contents/MacOS/libjli.dylib, 265): no suitable image found.  Did find:

           [exec] /Library/Java/JavaVirtualMachines/jdk1.8.0_60.jdk/Contents/MacOS/libjli.dylib: mach-o, but wrong architecture

           [exec] Result: 254

      and stop it.

      When i tried to execute > ant start.demo  it showed me:

      start.h2.check:

           [echo] Checking if h2 db should be started ...

       

      start.h2:

      a pop up window appeared with the following message:

      The JVM shared library "/Library/Java/JavaVirtualMachines/jdk1.8.0_60.jdk/Contents/Home/bin/../jre/lib/server/libjvm.dylib"

      does not contain the JNI_CreateJavaVM symbol.

       

      Obviously my jdk is java 1.8.0_60

      Do you have any idea how to sort this problem?

       

      Thanks in advance.

      Alex.