2 Replies Latest reply on Sep 21, 2015 3:59 PM by Chetan Joshi

    Spring Validation issue on JBoss 6.3

    Chetan Joshi Newbie

      Hi All,

       

      I am getting below error while using Spring Validator with JBoss 6.3

       

      org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS018014: Failed to parse XML descriptor "/standalone/deployments/MyApplication.ear/MyApplication.war/WEB-INF/lib/spring-modules-validation.jar/META-INF/valang.tld" at [13,23]

       

      After Googling ,I changed <body-content>None</body-content> to <body-content>empty</body-content>

      And now getting below error:

       

      Failed to define class org.springmodules.validation.valang.javascript.taglib.ValangValidateTag in Module "MyApplication.war:main" from Service Module Loader: java.lang.LinkageError: Failed to link org/springmodules/validation/valang/javascript/taglib/ValangValidateTag

       

      How can I Fix it? I can not change application code as we are migrating it from WAS 7.0 to JBoss 6.3

        • 1. Re: Spring Validation issue on JBoss 6.3
          Lyle Wang Novice

          It appears you've updated this thread here: https://developer.jboss.org/thread/203253

           

          NoClassDefFoundError: org/springframework/web/servlet/tags/RequestContextAwareTag

           

          This class is referenced (used by the tag file), but cannot be found in classpath.

          Confirm which jar contains this class and put the correct jar inside your deployment /WEB-INF/lib, or install it as JBoss custom module.

           

          If you still cannot sort it out, Is that possible to upload a simple reproducer (contains minimized files only necessary to reproduce the issue on an out-of-box EAP 6.3) ?

          • 2. Re: Spring Validation issue on JBoss 6.3
            Chetan Joshi Newbie

            That was a perfect reply and directed me in correct direction.

            I was thinking about modifying No library as thought it should work with the same library as it was on IBM WAS 7.0.

             

            To avoid java.lang.ClassNotFoundException: org.springframework.web.servlet.tags.RequestContextAwareTag

             

            I added org.springframework.web.servlet-3.1.0.M2.jar in classpath

             

            Then I got error java.lang.ClassNotFoundException: org.apache.commons.validator.ValidatorResources

             

            So added commons-validator-1.4.0.jar

            And problem got resolved.

             

            Thank you so much.