7 Replies Latest reply on Oct 9, 2015 2:00 PM by Jay SenSharma

    Unable to Shutdown WildFly 8.2

    Mustafa Mizrak Newbie

      I am unable to shutdown WildFly 8.2 with command:

       

      /usr/share/wildfly/bin/jboss-cli.sh --connect command=:shutdown
      

       

      No response returns and nothing happens.

       

      I am using ModeShape as submodule in WF 8.2. I am looking any safe solutions without killing the process to shutdown.

       

      Regards.

        • 1. Re: Unable to Shutdown WildFly 8.2
          Wolfgang Mayer Master

          What is your Java version?

          Do you get any messages in the server.log

          • 2. Re: Unable to Shutdown WildFly 8.2
            Mustafa Mizrak Newbie

            Java version: Oracle Java 1.8.0_31 (x64)

             

            No message in the server.log about the process.

            • 3. Re: Unable to Shutdown WildFly 8.2
              Frank Langelage Master

              What means "nothing happens"? Does this command hang endlessly or does it return immediately and you get back to the command prompt for entering the next command?

              You're using wildfly in standalone mode or domain mode?

              Did you use any port offset or change for startup of wildfly or change the ports in standalone.xml?

              • 4. Re: Unable to Shutdown WildFly 8.2
                Mustafa Mizrak Newbie

                What means "nothing happens"? Does this command hang endlessly or does it return immediately and you get back to the command prompt for entering the next command?

                      It hangs endlessly and no logs or changes.

                You're using wildfly in standalone mode or domain mode?

                    In standalone mode with modeshape.

                Did you use any port offset or change for startup of wildfly or change the ports in standalone.xml?

                 

                    configuration (standalone-modeshape.xml) :

                 

                <?xml version='1.0' encoding='UTF-8'?>
                
                <server xmlns="urn:jboss:domain:2.0">
                    <extensions>
                        <extension module="org.jboss.as.clustering.infinispan"/>
                        <extension module="org.jboss.as.connector"/>
                        <extension module="org.jboss.as.deployment-scanner"/>
                        <extension module="org.jboss.as.ee"/>
                        <extension module="org.jboss.as.ejb3"/>
                        <extension module="org.jboss.as.jaxrs"/>
                        <extension module="org.jboss.as.jdr"/>
                        <extension module="org.jboss.as.jmx"/>
                        <extension module="org.jboss.as.jpa"/>
                        <extension module="org.jboss.as.jsf"/>
                        <extension module="org.jboss.as.logging"/>
                        <extension module="org.jboss.as.mail"/>
                        <extension module="org.jboss.as.naming"/>
                        <extension module="org.jboss.as.pojo"/>
                        <extension module="org.jboss.as.remoting"/>
                        <extension module="org.jboss.as.sar"/>
                        <extension module="org.jboss.as.security"/>
                        <extension module="org.jboss.as.threads"/>
                        <extension module="org.jboss.as.transactions"/>
                        <extension module="org.jboss.as.webservices"/>
                        <extension module="org.jboss.as.weld"/>
                        <extension module="org.wildfly.extension.batch"/>
                        <extension module="org.wildfly.extension.io"/>
                        <extension module="org.wildfly.extension.undertow"/>
                        <extension module="org.modeshape"/>
                    </extensions>
                    <management>
                        <security-realms>
                            <security-realm name="ManagementRealm">
                                <authentication>
                                    <local default-user="$local"/>
                                    <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>
                                </authentication>
                                <authorization map-groups-to-roles="false">
                                    <properties path="mgmt-groups.properties" relative-to="jboss.server.config.dir"/>
                                </authorization>
                            </security-realm>
                            <security-realm name="ApplicationRealm">
                                <authentication>
                                    <local default-user="$local" allowed-users="*"/>
                                    <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>
                                </authentication>
                                <authorization>
                                    <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>
                                </authorization>
                            </security-realm>
                        </security-realms>
                        <audit-log>
                            <formatters>
                                <json-formatter name="json-formatter"/>
                            </formatters>
                            <handlers>
                                <file-handler name="file" formatter="json-formatter" relative-to="jboss.server.data.dir" path="audit-log.log"/>
                            </handlers>
                            <logger log-boot="true" log-read-only="false" enabled="false">
                                <handlers>
                                    <handler name="file"/>
                                </handlers>
                            </logger>
                        </audit-log>
                        <management-interfaces>
                            <http-interface security-realm="ManagementRealm" http-upgrade-enabled="true">
                                <socket-binding http="management-http"/>
                            </http-interface>
                        </management-interfaces>
                        <access-control provider="simple">
                            <role-mapping>
                                <role name="SuperUser">
                                    <include>
                                        <user name="$local"/>
                                    </include>
                                </role>
                            </role-mapping>
                        </access-control>
                    </management>
                    <profile>
                        <subsystem xmlns="urn:jboss:domain:logging:2.0">
                            <console-handler name="CONSOLE">
                                <level name="INFO"/>
                                <formatter>
                                    <named-formatter name="COLOR-PATTERN"/>
                                </formatter>
                            </console-handler>
                            <periodic-rotating-file-handler name="FILE" autoflush="true">
                                <formatter>
                                    <named-formatter name="PATTERN"/>
                                </formatter>
                                <file relative-to="jboss.server.log.dir" path="server.log"/>
                                <suffix value=".yyyy-MM-dd"/>
                                <append value="true"/>
                            </periodic-rotating-file-handler>
                            <logger category="com.arjuna">
                                <level name="WARN"/>
                            </logger>
                            <logger category="org.apache.tomcat.util.modeler">
                                <level name="WARN"/>
                            </logger>
                            <logger category="org.jboss.as.config">
                                <level name="DEBUG"/>
                            </logger>
                            <logger category="sun.rmi">
                                <level name="WARN"/>
                            </logger>
                            <logger category="jacorb">
                                <level name="WARN"/>
                            </logger>
                            <logger category="jacorb.config">
                                <level name="ERROR"/>
                            </logger>
                            <root-logger>
                                <level name="INFO"/>
                                <handlers>
                                    <handler name="CONSOLE"/>
                                    <handler name="FILE"/>
                                </handlers>
                            </root-logger>
                            <formatter name="PATTERN">
                                <pattern-formatter pattern="%d{yyyy-MM-dd HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>
                            </formatter>
                            <formatter name="COLOR-PATTERN">
                                <pattern-formatter pattern="%K{level}%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>
                            </formatter>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:batch:1.0">
                            <job-repository>
                                <in-memory/>
                            </job-repository>
                            <thread-pool>
                                <max-threads count="10"/>
                                <keepalive-time time="100" unit="milliseconds"/>
                            </thread-pool>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:datasources:2.0">
                            <datasources>
                                <datasource jndi-name="java:jboss/datasources/ExampleDS" pool-name="ExampleDS" enabled="true" use-java-context="true">
                                    <connection-url>jdbc:h2:mem:test;DB_CLOSE_DELAY=-1;DB_CLOSE_ON_EXIT=FALSE</connection-url>
                                    <driver>h2</driver>
                                    <security>
                                        <user-name>sa</user-name>
                                        <password>sa</password>
                                    </security>
                                </datasource>
                
                                <datasource jndi-name="java:/datasources/ModeShapeDS" pool-name="ModeShapeDS" enabled="true" use-java-context="true">
                                    <connection-url>jdbc:jcr:jndi:jcr?repositoryName=artifacts</connection-url>
                                    <driver>modeshape</driver>
                                    <connection-property name="workspace">extra</connection-property>
                                    <security>
                                        <user-name>admin</user-name>
                                        <password>admin</password>
                                    </security>
                                </datasource>
                                <drivers>
                                    <driver name="h2" module="com.h2database.h2">
                                        <xa-datasource-class>org.h2.jdbcx.JdbcDataSource</xa-datasource-class>
                                    </driver>
                                    <driver name="modeshape" module="org.modeshape.jdbc">
                                        <driver-class>org.modeshape.jdbc.LocalJcrDriver</driver-class>
                                    </driver>
                                </drivers>
                            </datasources>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:deployment-scanner:2.0">
                            <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000" runtime-failure-causes-rollback="${jboss.deployment.scanner.rollback.on.failure:false}"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:ee:2.0">
                            <spec-descriptor-property-replacement>false</spec-descriptor-property-replacement>
                            <jboss-descriptor-property-replacement>true</jboss-descriptor-property-replacement>
                            <annotation-property-replacement>false</annotation-property-replacement>
                            <concurrent>
                                <context-services>
                                    <context-service name="default" jndi-name="java:jboss/ee/concurrency/context/default" use-transaction-setup-provider="true"/>
                                </context-services>
                                <managed-executor-services>
                                    <managed-executor-service name="default" jndi-name="java:jboss/ee/concurrency/executor/default" context-service="default" hung-task-threshold="60000" core-threads="5" max-threads="25" keepalive-time="5000"/>
                                </managed-executor-services>
                                <managed-scheduled-executor-services>
                                    <managed-scheduled-executor-service name="default" jndi-name="java:jboss/ee/concurrency/scheduler/default" context-service="default" hung-task-threshold="60000" core-threads="2" keepalive-time="3000"/>
                                </managed-scheduled-executor-services>
                                <managed-thread-factories>
                                    <managed-thread-factory name="default" jndi-name="java:jboss/ee/concurrency/factory/default" context-service="default"/>
                                </managed-thread-factories>
                            </concurrent>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:ejb3:2.0">
                            <session-bean>
                                <stateless>
                                    <bean-instance-pool-ref pool-name="slsb-strict-max-pool"/>
                                </stateless>
                                <stateful default-access-timeout="5000" cache-ref="simple" passivation-disabled-cache-ref="simple"/>
                                <singleton default-access-timeout="5000"/>
                            </session-bean>
                            <pools>
                                <bean-instance-pools>
                                    <strict-max-pool name="slsb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
                                    <strict-max-pool name="mdb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
                                </bean-instance-pools>
                            </pools>
                            <caches>
                                <cache name="simple"/>
                                <cache name="distributable" aliases="passivating clustered" passivation-store-ref="infinispan"/>
                            </caches>
                            <passivation-stores>
                                <passivation-store name="infinispan" cache-container="ejb" max-size="10000"/>
                            </passivation-stores>
                            <async thread-pool-name="default"/>
                            <timer-service thread-pool-name="default" default-data-store="default-file-store">
                                <data-stores>
                                    <file-data-store name="default-file-store" path="timer-service-data" relative-to="jboss.server.data.dir"/>
                                </data-stores>
                            </timer-service>
                            <remote connector-ref="http-remoting-connector" thread-pool-name="default"/>
                            <thread-pools>
                                <thread-pool name="default">
                                    <max-threads count="10"/>
                                    <keepalive-time time="100" unit="milliseconds"/>
                                </thread-pool>
                            </thread-pools>
                            <default-security-domain value="other"/>
                            <default-missing-method-permissions-deny-access value="true"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:io:1.0">
                            <worker name="default" io-threads="3"/>
                            <buffer-pool name="default" buffer-size="16384" buffers-per-slice="128"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:infinispan:2.0">
                            <cache-container name="web" default-cache="passivation" module="org.wildfly.clustering.web.infinispan">
                                <local-cache name="passivation" batching="true">
                                    <file-store passivation="true" purge="false"/>
                                </local-cache>
                                <local-cache name="persistent" batching="true">
                                    <file-store passivation="false" purge="false"/>
                                </local-cache>
                            </cache-container>
                            <cache-container name="ejb" aliases="sfsb" default-cache="passivation" module="org.wildfly.clustering.ejb.infinispan">
                                <local-cache name="passivation" batching="true">
                                    <file-store passivation="true" purge="false"/>
                                </local-cache>
                                <local-cache name="persistent" batching="true">
                                    <file-store passivation="false" purge="false"/>
                                </local-cache>
                            </cache-container>
                            <cache-container name="hibernate" default-cache="local-query" module="org.hibernate">
                                <local-cache name="entity">
                                    <transaction mode="NON_XA"/>
                                    <eviction strategy="LRU" max-entries="10000"/>
                                    <expiration max-idle="100000"/>
                                </local-cache>
                                <local-cache name="local-query">
                                    <transaction mode="NONE"/>
                                    <eviction strategy="LRU" max-entries="10000"/>
                                    <expiration max-idle="100000"/>
                                </local-cache>
                                <local-cache name="timestamps">
                                    <transaction mode="NONE"/>
                                    <eviction strategy="NONE"/>
                                </local-cache>
                            </cache-container>
                            <!-- Each ModeShape repository uses one (or more) cache in a cache container. We define a single container
                                 named "modeshape" (other names require specifying the container names in each repository configuration,
                                 with a "sample" cache (each repository assumes the cache name matches the repository name). -->
                            <cache-container name="modeshape" default-cache="sample" module="org.modeshape">
                                <local-cache name="sample">
                                    <!--READ_COMMITTED is required to ensure multiple writer threads can update the same node(s)-->
                                    <locking isolation="READ_COMMITTED"/>
                                    <!-- ModeShape requires transactions -->
                                    <transaction mode="NON_XA"/>
                                    <!-- Use a cache with file-backed write-through storage. File-backed storage is simple, but not necessarily the fastest. -->
                                    <file-store path="modeshape/store/sample" passivation="false" purge="false"/>
                                </local-cache>
                                <local-cache name="artifacts">
                                    <!--READ_COMMITTED is required to ensure multiple writer threads can update the same node(s)-->
                                    <locking isolation="READ_COMMITTED"/>
                                    <!-- ModeShape requires transactions -->
                                    <transaction mode="NON_XA"/>
                                    <!-- Use a cache with file-backed write-through storage. File-backed storage is simple, but not necessarily the fastest. -->
                                    <file-store path="modeshape/store/artifacts" passivation="false" purge="false"/>
                                </local-cache>
                            </cache-container>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:modeshape:2.0">
                            <!--The list of web applications that is packaged inside the kit and should be deployed when the subsystem starts up-->
                            <webapp name="modeshape-rest.war"/>
                            <webapp name="modeshape-webdav.war"/>
                            <webapp name="modeshape-cmis.war"/>
                            <webapp name="modeshape-explorer.war"/>
                
                            <!-- A sample repository that uses the "sample" cache in the "modeshape" container. All content, binary values,
                                 and indexes are stored within the server's data directory. This is the simplest way to configure a repository
                                 that uses defaults for everything; feel free to change and specify other configuration options.  -->
                            <repository name="sample" anonymous-roles="admin"/>
                            <!-- A second sample repository that defines additional non-default components such as extra workspaces and sequencers. -->
                            <repository name="artifacts" anonymous-roles="admin">
                                <!--Store binary artifacts on the FS under ${jboss.data.dir}/modeshape/artifacts/binaries -->
                                <file-binary-storage/>
                                <!-- Define 3 workspaces to exist upon startup -->
                                <workspaces default-workspace="default" allow-workspace-creation="false">
                                    <workspace name="default">
                                        <initial-content>initial-content-default.xml</initial-content>
                                    </workspace>
                                    <workspace name="other"/>
                                    <workspace name="extra"/>
                                </workspaces>
                                <!--
                                Define a bunch of sequencers. Carefully note the differences in the path expressions; some sequencers
                                do not generate a node to represent a file, while other sequencers (e.g., XML, XSD, WSDL, ZIP) always
                                generate a node based upon the filename.
                                The sequencer names are unique identifiers within the configuration, and should not contain spaces.
                                Also, some of the sequencer configurations use the fully-qualified classname, while other use the
                                short alias (which only works for the sequencer provided by ModeShape). -->
                                <sequencers>
                                    <sequencer name="delimited-text-sequencer" classname="org.modeshape.sequencer.text.DelimitedTextSequencer"
                                               module="org.modeshape.sequencer.text" splitPattern=",">
                                        <path-expression>/files(//*.csv[*])/jcr:content[@jcr:data] => /derived/text/delimited/$1</path-expression>
                                    </sequencer>
                                    <sequencer name="fixed-width-text-sequencer"
                                               classname="org.modeshape.sequencer.text.FixedWidthTextSequencer"
                                               module="org.modeshape.sequencer.text" commentMarker="#">
                                        <path-expression>/files(//*.txt[*])/jcr:content[@jcr:data] => /derived/text/fixedWidth/$1</path-expression>
                                    </sequencer>
                                    <sequencer name="ddl-sequencer" classname="org.modeshape.sequencer.ddl.DdlSequencer"
                                               module="org.modeshape.sequencer.ddl">
                                        <path-expression>/files(//*.ddl[*])/jcr:content[@jcr:data] => /derived/ddl/$1</path-expression>
                                    </sequencer>
                                    <!--
                                        For the java & class sequencer we need to explicitly define the module, as it does not map 1-1 to the classname
                                    -->
                                    <sequencer name="java-source-sequencer" classname="org.modeshape.sequencer.javafile.JavaFileSequencer"
                                               module="org.modeshape.sequencer.java">
                                        <path-expression>/files//(*.java[*])/jcr:content[@jcr:data] => /derived/java</path-expression>
                                    </sequencer>
                                    <sequencer name="java-class-sequencer" classname="org.modeshape.sequencer.classfile.ClassFileSequencer"
                                               module="org.modeshape.sequencer.java">
                                        <path-expression>/files//(*.class[*])/jcr:content[@jcr:data] => /derived/class</path-expression>
                                    </sequencer>
                                    <sequencer name="cnd-sequencer" classname="cnd" module="org.modeshape">
                                        <path-expression>default:/files(//*.cnd[*])/jcr:content[@jcr:data] => /derived/cnd/$1</path-expression>
                                    </sequencer>
                                    <sequencer name="msoffice-sequencer" classname="msoffice" module="org.modeshape.sequencer.msoffice">
                                        <path-expression>/files(//*.(xls|ppt|doc)[*])/jcr:content[@jcr:data] => /derived/msoffice/$1</path-expression>
                                    </sequencer>
                                    <sequencer name="teiid-model-sequencer" classname="model" module="org.modeshape.sequencer.teiid">
                                      <path-expression>/files(//*.xmi[*])/jcr:content[@jcr:data] => /derived/teiid/models/$1</path-expression>
                                    </sequencer>
                                    <sequencer name="teiid-vdb-sequencer" classname="vdb" module="org.modeshape.sequencer.teiid">
                                      <path-expression>/files(//*.vdb[*])/jcr:content[@jcr:data] => /derived/teiid/vdbs/$1</path-expression>
                                    </sequencer>
                                    <!--
                                     The XSD, XML, WSDL, and ZIP sequencers all generate a node for the input documents, and so we don't want the filename to
                                     be included in the output path. Therefore, only the relative path under '/files' and above '*.xsd' (or '*.wsdl'
                                     or '*.xml') is captured in the input path. -->
                                    <sequencer name="xsd-sequencer" classname="xsd" module="org.modeshape.sequencer.xsd">
                                        <path-expression>/files(//*).xsd[*]/jcr:content[@jcr:data] => /derived/xsd/$1</path-expression>
                                    </sequencer>
                                    <sequencer name="wsdl-sequencer" classname="wsdl" module="org.modeshape.sequencer.wsdl">
                                        <path-expression>/files(//)*.wsdl[*]/jcr:content[@jcr:data] => /derived/wsdl/$1</path-expression>
                                    </sequencer>
                                    <sequencer name="xml-sequencer" classname="xml" module="org.modeshape.sequencer.xml">
                                        <path-expression>/files(//)*.xml[*]/jcr:content[@jcr:data] => /derived/xml/$1</path-expression>
                                    </sequencer>
                                    <sequencer name="zip-sequencer" classname="zip" module="org.modeshape.sequencer.zip">
                                        <path-expression>/files(//*.zip[*])/jcr:content[@jcr:data] => /derived/zip/$1</path-expression>
                                    </sequencer>
                                    <sequencer name="image-sequencer" classname="image" module="org.modeshape.sequencer.image">
                                        <path-expression>/files(//*.(png|jpg|gif)[*])/jcr:content[@jcr:data] => /derived/image/$1</path-expression>
                                    </sequencer>
                                    <sequencer name="mp3-sequencer" classname="mp3" module="org.modeshape.sequencer.mp3">
                                        <path-expression>/files(//*.mp3[*])/jcr:content[@jcr:data] => /derived/mp3/$1</path-expression>
                                    </sequencer>
                                </sequencers>
                                <text-extractors>
                                    <text-extractor name="tika-extractor" classname="tika" module="org.modeshape.extractor.tika"/>
                                </text-extractors>
                            </repository>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>
                        <subsystem xmlns="urn:jboss:domain:jca:2.0">
                            <archive-validation enabled="true" fail-on-error="true" fail-on-warn="false"/>
                            <bean-validation enabled="true"/>
                            <default-workmanager>
                                <short-running-threads>
                                    <core-threads count="50"/>
                                    <queue-length count="50"/>
                                    <max-threads count="50"/>
                                    <keepalive-time time="10" unit="seconds"/>
                                </short-running-threads>
                                <long-running-threads>
                                    <core-threads count="50"/>
                                    <queue-length count="50"/>
                                    <max-threads count="50"/>
                                    <keepalive-time time="10" unit="seconds"/>
                                </long-running-threads>
                            </default-workmanager>
                            <cached-connection-manager/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:jdr:1.0"/>
                        <subsystem xmlns="urn:jboss:domain:jmx:1.3">
                            <expose-resolved-model/>
                            <expose-expression-model/>
                            <remoting-connector/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:jpa:1.1">
                            <jpa default-datasource="" default-extended-persistence-inheritance="DEEP"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:jsf:1.0"/>
                        <subsystem xmlns="urn:jboss:domain:mail:2.0">
                            <mail-session name="default" jndi-name="java:jboss/mail/Default">
                                <smtp-server outbound-socket-binding-ref="mail-smtp"/>
                            </mail-session>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:naming:2.0">
                            <remote-naming/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:pojo:1.0"/>
                        <subsystem xmlns="urn:jboss:domain:remoting:2.0">
                            <http-connector name="http-remoting-connector" connector-ref="default" security-realm="ApplicationRealm"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:resource-adapters:2.0"/>
                        <subsystem xmlns="urn:jboss:domain:sar:1.0"/>
                        <subsystem xmlns="urn:jboss:domain:security:1.2">
                            <security-domains>
                                <security-domain name="other" cache-type="default">
                                    <authentication>
                                        <login-module code="Remoting" flag="optional">
                                            <module-option name="password-stacking" value="useFirstPass"/>
                                        </login-module>
                                        <login-module code="RealmDirect" flag="required">
                                            <module-option name="password-stacking" value="useFirstPass"/>
                                        </login-module>
                                    </authentication>
                                </security-domain>
                                <security-domain name="jboss-web-policy" cache-type="default">
                                    <authorization>
                                        <policy-module code="Delegating" flag="required"/>
                                    </authorization>
                                </security-domain>
                                <security-domain name="jboss-ejb-policy" cache-type="default">
                                    <authorization>
                                        <policy-module code="Delegating" flag="required"/>
                                    </authorization>
                                </security-domain>
                                <security-domain name="modeshape-security" cache-type="default">
                                    <authentication>
                                        <login-module code="RealmDirect" flag="required">
                                            <module-option name="password-stacking" value="useFirstPass"/>
                                        </login-module>
                                    </authentication>
                                </security-domain>
                            </security-domains>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:threads:1.1"/>
                        <subsystem xmlns="urn:jboss:domain:transactions:2.0">
                            <core-environment>
                                <process-id>
                                    <uuid/>
                                </process-id>
                            </core-environment>
                            <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>
                            <coordinator-environment default-timeout="300"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:undertow:1.0">
                            <buffer-caches>
                                <buffer-cache name="default" buffer-size="1024" buffers-per-region="1024" max-regions="10"/>
                            </buffer-caches>
                            <server name="default-server">
                                <http-listener name="default" socket-binding="http"/>
                                <host name="default-host" alias="localhost">
                                    <location name="/" handler="welcome-content"/>
                                </host>
                            </server>
                            <servlet-container name="default" default-buffer-cache="default" stack-trace-on-error="local-only">
                                <jsp-config/>
                                <persistent-sessions/>
                            </servlet-container>
                            <handlers>
                                <file name="welcome-content" path="${jboss.home.dir}/welcome-content" directory-listing="true"/>
                            </handlers>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:webservices:1.2">
                            <modify-wsdl-address>true</modify-wsdl-address>
                            <wsdl-host>${jboss.bind.address:127.0.0.1}</wsdl-host>
                            <endpoint-config name="Standard-Endpoint-Config"/>
                            <endpoint-config name="Recording-Endpoint-Config">
                                <pre-handler-chain name="recording-handlers" protocol-bindings="##SOAP11_HTTP ##SOAP11_HTTP_MTOM ##SOAP12_HTTP ##SOAP12_HTTP_MTOM">
                                    <handler name="RecordingHandler" class="org.jboss.ws.common.invocation.RecordingServerHandler"/>
                                </pre-handler-chain>
                            </endpoint-config>
                            <client-config name="Standard-Client-Config"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:weld:2.0"/>
                    </profile>
                    <interfaces>
                        <interface name="management">
                            <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>
                        </interface>
                        <interface name="public">
                            <inet-address value="${jboss.bind.address:127.0.0.1}"/>
                        </interface>
                        <!-- TODO - only show this if the jacorb subsystem is added  -->
                        <interface name="unsecure">
                            <!--
                              ~  Used for IIOP sockets in the standard configuration.
                              ~                  To secure JacORB you need to setup SSL 
                              -->
                            <inet-address value="${jboss.bind.address.unsecure:127.0.0.1}"/>
                        </interface>
                    </interfaces>
                    <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">
                        <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>
                        <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>
                        <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9993}"/>
                        <socket-binding name="ajp" port="${jboss.ajp.port:8009}"/>
                        <socket-binding name="http" port="${jboss.http.port:8080}"/>
                        <socket-binding name="https" port="${jboss.https.port:8443}"/>
                        <socket-binding name="txn-recovery-environment" port="4712"/>
                        <socket-binding name="txn-status-manager" port="4713"/>
                        <outbound-socket-binding name="mail-smtp">
                            <remote-destination host="localhost" port="25"/>
                        </outbound-socket-binding>
                    </socket-binding-group>
                </server>
                
                • 5. Re: Unable to Shutdown WildFly 8.2
                  Frank Langelage Master

                  As far as I know, with the "--controller" option jboss-cli connects to localhost:9990. Is there really the Wildfly server listening or someone else?

                  In your server.log you should see something like

                  09.10. 06:01:08,843 INFO  [org.wildfly.extension.undertow#startListening] JBAS017519: Undertow HTTP listener http listening on /0.0.0.0:8580

                  09.10. 06:01:13,018 INFO  [org.wildfly.extension.undertow#startListening] JBAS017519: Undertow HTTPS listener https listening on /0.0.0.0:8943

                  09.10. 06:02:08,062 INFO  [org.jboss.as#logAdminConsole] JBAS015961: Http management interface listening on http://0.0.0.0:10490/management

                  09.10. 06:02:08,062 INFO  [org.jboss.as#logAdminConsole] JBAS015951: Admin console listening on http://0.0.0.0:10490

                  The addresses and ports your wildfly server is listening on.

                  In my case I used a port-offset of 500 and binding address 0.0.0.0 = all IPs.

                  • 6. Re: Unable to Shutdown WildFly 8.2
                    Mustafa Mizrak Newbie

                    Frank Langelage wrote:

                     

                    As far as I know, with the "--controller" option jboss-cli connects to localhost:9990. Is there really the Wildfly server listening or someone else?

                    
                    
                    
                    
                    <interfaces>
                    
                    
                        
                    <interface name="management">
                    
                    
                            
                    <inet-address value="${jboss.bind.address.management:0.0.0.0}"/>
                    
                    
                        
                    </interface>
                    
                    
                        
                    <interface name="public">
                    
                    
                            
                    <inet-address value="${jboss.bind.address:0.0.0.0}"/>
                    
                    
                        
                    </interface>
                    
                    
                        
                    <interface name="unsecure">
                    
                    
                            
                    <inet-address value="${jboss.bind.address.unsecure:0.0.0.0}"/>
                    
                    
                        
                    </interface>
                    
                    
                    
                    </interfaces>
                    
                    
                    
                    

                     

                    The actual binding config is above. Sorry for binding with localhost config.

                    • 7. Re: Unable to Shutdown WildFly 8.2
                      Jay SenSharma Master

                      Hello Mustafa,

                       

                         After restarting your WildFLy 8.2 can you please share the log snippet until WildFly start message in the log.

                       

                         Also can you open the file "wildfly-8.2.1.Final/bin/jboss-cli.xml" and let us know which port is mentioned in the following section?  Wheteever port is mentioned there the JBoss CLI will try to connect to that port by default until you specify the changes port using "--controller" option.

                       

                          <default-controller>

                              <protocol>http-remoting</protocol>

                              <host>localhost</host>

                              <port>9990</port>

                          </default-controller>

                       

                        

                         Another thing you can test is use the  following netstat command to list all the ports which are opened by it:

                       

                         netstat -tnlp | grep $WILDFLY_PID

                       

                       

                         If you find that its management port is different then via CLI try the following command:

                       

                         ./jboss-cli.sh --controller=localhost:$PORT  --connect command=:shutdown